1

Currently I am executing a Content Migration from Production to our Development environment. We are using SDL Web 8.5. The CMS database is restored and I followed all steps from the SDL Documentation.

The CME works fine except for publishing. Publishing doesn't work and it has to do with the Business Process Types. It is using and Topology Type which is not available:

enter image description here

The situation is that at this implementation, each environment has different Topology Types. Before the content migration the development environment was using another Toplogy Type (with another name). I cannot change anything to this Business Process type since items are published against this one, but I also cannot unpublish...

  • 1
    Peter,normally the best practice is to keep all the environment with same business process type and topology type, example: Staging and Live, It depends what you want to achieve , Please let us know if you want to keep the topology type similar to production or like what it was on dev, if you had same ( business process type , Purpose ) it would have been easy. Provide more details. – Anand NS Apr 22 at 15:39
  • I was very surprised when I saw this implementation, so I don't want to keep it this way. Highest priority for me is to make the Development environment work again, but I also want to make the Topology Types identical on each environment. – Peter van der Lugt Apr 22 at 18:05
3

The solution was very simple. I created a new Business Process Type, based on the Topology Type of the Development environment and added that to the publication. So publishing works now.

Next step is implementing the same Topology Type on all servers, but that's not part of this question.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.