1

We created some Page Types for the users to create pages in XPM, but when we click "Create Page" after selecting some Page Type and filling in the Page title and file name, we always get a 404 error.

We checked the CMS, those Pages have been created in right place, but they are not auto published to staging. How can we configure this?

We use SDL Web 8.5. The XPM function works fine.

  • When you create the page in XPM via the page type, if you monitor the network tab in your browser there should be a call to publish the page if I remember correctly. I've had issues in the past where this call returned an error - but I was seeing it when the user clicked "Finish Editing" which should publish the item to staging. I'd start there to see if you are getting a similar response. – Josh Hebb May 12 at 12:03
  • Is your XPM Session Preview working properly? Creating a new Page in XPM relies on Session Preview to render the Page before it is published. – Rick Pannekoek May 12 at 17:43
  • I tested this function again and found: 1. after clicking 'create page', it will show 404 error. I checked it in CMS, the page has been created but not published. I also checked the publish queue, it is in publish queue! 2. if I refresh the page, the right page will be shown because it's publishing is finished. Any idea about this? – Ivy Chen May 13 at 5:09
2

What you describe in your last comment is the normal behavior when the Session Preview is turned off or is not working properly. I have witnessed the exact same flow when I'd manually turned off Session Preview (as part of an earlier investigation on a project).

So... as Rick mentioned, check your Session (Preview) setup. This includes the required microservices (Preview and Session-enabled Content Service) being installed and registered and the Session Preview not disabled (the option is inverted) in the CME Settings section, see below.

enter image description here

| improve this answer | |
  • I can't see the image which you uploaded. Can you describe how to check the session preview setting in CMS? we are using Web 8.5. thanks a lot – Ivy Chen May 14 at 2:31
  • You can click the image which will open it in a larger format. To access the Settings from the CME, click the burger menu located on the top left which will slide in a menu in which you can find that option. – Atila Sos May 14 at 14:18
  • thanks Atila. I checked the session preview setting under inline editing setting. the option 'No' is selected for 'Disable session preview'. so I think the session preview is enabled. but the issue is still there. any other things can I check? – Ivy Chen May 18 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.