1

I am installing the DXA model extension using SDL Add-On feature by following the steps mentioned in SDL Documentation. It's stuck with Status as pending activation. I believe this might be because of something missing(maybe some rights or access to some port). I can't see any error logged into the Event viewer or Add-on service log.

I have already checked a similar TREX question DXA Model Extension got stuck in a Pending activation Status and verified that I have environment variable configured and I can access content delivery services on my content manager machine.

Can anyone suggest what else I can check?

  • Did you restart the content service after the DXA model extension install in the add-on? – Velmurugan May 25 at 14:14
  • Can you check, Is there any error anything in the content service logs? – Velmurugan May 25 at 14:20
  • Yes, I restarted the service and no error in my session content service. Wondering if this addon need any configuration? Even I can't see any changes in my Content service.. – Mukesh Kumar May 25 at 14:38
  • Can you also check "\session\extensions\dxa-model-extension.zip" this file downloaded in the extensions folder or not? also ensure content service server has access to add-on service endpoint? – Velmurugan May 25 at 14:47
  • Thanks @Velmurugan, \session\extensions folder is not available. I can access Add on service from CD server. – Mukesh Kumar May 25 at 14:52
2

Try the following steps to troubleshoot.

  • Ensure ContentServiceCapability registered with the discovery (DXA model extension works without configuration it's mandatory to register the ContentServiceCapability before content service restart, either install the service with auto-register or run the discovery registration and then restart the service, otherwise add-on service doesn't know about the service role)
  • Stop the add-on service and restart the session content service to leave it 2 to 3mins, I would expect session content service would go down and also expect to see this below error message in your cd_core.logs

2020-05-25 17:00:10,554 ERROR [main] AddonClientFacade - Add-on service specified by URL: 'http://localhost:83/addon' is not up and running but it's mandatory for service to work properly java.lang.RuntimeException: Retry limit exceeded. at com.sdl.delivery.addon.client.api.AddonClientFacade.registerAddonsToDownload(AddonClientFacade.java:160) at com.sdl.delivery.service.WinServiceContainer.main(WinServiceContainer.java:41) Caused by: org.springframework.web.client.ResourceAccessException: I/O error on GET request for "http://localhost:83/addon/api/v1/health": Connection refused: connect; nested

  • Also, try to enable DEBUG logs to see what it's going on
  • Ensure add-on service URL either passed in the service start-up parameters or the following below environment variables created as per your environment
    # Create the system environment variables   
    [System.Environment]::SetEnvironmentVariable('addonserviceurl','http://localhost:83/addon',[System.EnvironmentVariableTarget]::Machine)

    [System.Environment]::SetEnvironmentVariable('cdenvironment','staging',[System.EnvironmentVariableTarget]::Machine)
  • In the application.properties ensure the following properties configured
# add-on heartbeat interval. determines how often we should report live status of a service to add-on service.
# default value is every 60000 millis = 1 minute.
addon.heartbeat.interval=60000

I hope it helps

| improve this answer | |
  • Thanks @Velmurugan. During debugging I saw that issue was indeed because of missing environment variables. I didn't added the cdenvironment variable to "staging" as my CD environment was having both Staging and Live services. – Mukesh Kumar May 25 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.