2

I tried to install DXA 2.2 Java to Red Hat Linux 8.2. However, When Executing prepare.sh, the Following build Error Occurred:

There is no '2.2.0-SNAPSHOT' on following URL, which is seen in error message. https://repo.maven.apache.org/maven2/com/sdl/dxa/dxa-builder/

Why is dxa-builder:2.2.0-SNAPSHOT missing?

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'installer'.
> Could not resolve all artifacts for configuration ':classpath'.
   > Could not find com.sdl.dxa:dxa-builder:2.2.0-SNAPSHOT.
     Searched in the following locations:
       - file:/root/.m2/repository/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/maven-metadata.xml
       - file:/root/.m2/repository/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/dxa-builder-2.2.0-SNAPSHOT.pom
       - file:/root/.m2/repository/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/dxa-builder-2.2.0-SNAPSHOT.jar
       - https://repo.maven.apache.org/maven2/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/maven-metadata.xml
       - https://repo.maven.apache.org/maven2/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/dxa-builder-2.2.0-SNAPSHOT.pom
       - https://repo.maven.apache.org/maven2/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/dxa-builder-2.2.0-SNAPSHOT.jar
       - https://oss.sonatype.org/content/repositories/snapshots/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/maven-metadata.xml
       - https://oss.sonatype.org/content/repositories/snapshots/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/dxa-builder-2.2.0-SNAPSHOT.pom
       - https://oss.sonatype.org/content/repositories/snapshots/com/sdl/dxa/dxa-builder/2.2.0-SNAPSHOT/dxa-builder-2.2.0-SNAPSHOT.jar

Update In DXA 2.2's known issues, there is an issue 'Version 2.2.1 required when building a Java web application'

https://docs.sdl.com/784837/743044/sdl-digital-experience-accelerator-2-2/issue--version-------------2-2-1-required-when-building-a-java-web-application

So I download DXA 2.2.1, and executed following command in dxa-webapp directory.

mvn clean package

Then, following error occurred.

[ERROR] Failed to execute goal on project dxa-webapp: Could not resolve dependencies for project com.sdl.dxa:dxa-webapp:war:2.2.1: Could not find artifact com.sdl.tridion.xo:xo-compatible-client:jar:11.0.0-1057 in central (https://repo.maven.apache.org/maven2) -> [Help 1]

I downloaded dxa-web-application-java-DXA_2.2.5_Hotfix.tar.gz from this page. https://github.com/sdl/dxa-web-application-java/releases/tag/DXA_2.2.5_Hotfix

Then upload it to Linux and it already contains 'dxa-webapp' directory, so I execute following command mvn clean package -P 2.2.5

I get this command from following page(SDL DXA documentation) https://docs.sdl.com/792164/548959/sdl-digital-experience-accelerator-2-0/building-your-web-application--java-

Then followng error occurred.

[INFO] Scanning for projects...
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[FATAL] 'parent.artifactId' is missing. @ line 7, column 13
 @
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]
[ERROR]   The project com.sdl.dxa:dxa-webapp:2.2.5 (/home/ec2-user/dxa-web-application-java-DXA_2.2.5_Hotfix/dxa-webapp/pom.xml) has 1 error
[ERROR]     'parent.artifactId' is missing. @ line 7, column 13
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException

I tried DXA 2.2.4, it failed by different error. So I tried DXA 2.2.3, then build succeeded and a file dxa-webapp.war was generated. I'm not sure what was wrong building 2.2.5 and 2.2.4.

  • there was an issue with the DXA 2.2.0 release that it referenced wrong (internal/not published) versions of some of the CD artifacts, Can you try DXA 2.2.5? – Velmurugan Oct 16 at 6:41
  • Building by 'mvn clean package' command for DXA 2.2.5 and DXA 2.2.4 failed, but succeeded for DXA 2.2.3. I wrote result by editing my post. I'm not sure using 2.2.3 is good solution. – Hirokazu Shikata Oct 16 at 8:20
  • Go far 2.2.3, there are no major changes in 2.2.5, just a few references corrections AFAIK – Velmurugan Oct 16 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.