0

We have separate server for CMS and Publisher. On publisher server, we installed only publisher capabilities. Now Pages and binaries publishing works fine but custom events which were subscribed for publish events were not triggering.

Observations: When i restart the publisher service, custom event handler code is not loading but it loads randomly, I can see that information in event viewer.

Can you please help me to narrow down the issue? Is this issue because we installed only publisher capabilities?

9
  • please refer to this link for more details – Anand NS Jun 8 at 13:34
  • did you deploy the event system on both CM and Publisher and updated the Tridion Content Manager config, what do you on the Event Viewer logs on boh CM and Pubisher – Anand NS Jun 8 at 13:35
  • Yes, event handler dll was deployed on both the servers. I can see logs updated on cms server and custom events were triggered on this server. But i see only empty log on publisher server. – Tridion New User Jun 8 at 13:44
  • I updated the tridion content manager config on both the servers – Tridion New User Jun 8 at 13:44
  • 1
    share your subscribed event? To debug Publisher Content Manager, use Visual Studio Debugger to attach to a running host process. docs.sdl.com/816112/502913/… – Velmurugan Jun 8 at 20:19
1

You need to have Service Host process running on publisher also. If it is not running, then probably your event system code will not trigger. Besides this, check the usual: configs, filepaths, check if it is loading properly, check the access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.