1

While running(start) the server in Eclipse, I see below Error being logged in console. While it is able to locate one of the xpm.js, it is unable to locate the 2nd xpm.js as highlighted in RED below.

enter image description here

So far as checked in whole eclipse solution, I have only one below code in one jsp file:

<xpm:if-enabled>
    <script src="${markup.versionedContent('/assets/scripts/xpm.js')}"></script>
</xpm:if-enabled>

I think, the above <xpm:if-enabled /> corresponds to the below console line, which is working & fine

INFO  c.n.d.service.MBDispatcherServlet-
***Request URL:http://localhost:8071/en/system/v2.2/assets/scripts/xpm.js

Can you please let me know what is causing the below error/warning and how to fix it ?

WARN  c.s.w.c.i.i.StaticContentInterceptor - Static resource not found in 
static content provider for /en/system/assets/scripts/xpm.js. Fallback to webapp content

Please refer the first console image for a stack trace

3
  • Can you share the version of dxa-java you are using , did you upgrade the dxa-java recently
    – Anand NS
    Aug 17 at 10:21
  • No upgrade recently. DXA version is 2.2.3 Aug 17 at 11:49
  • I don't think this is a matter of being able to locate xpm.js on the first request, but not on the second request. In general, all Static Item requests are logged at INFO level, but handling the xpm.js request results in a WARNing that such item in not stored as a Binary in the CD Data Store and it falls back to reading it from disk directly ("fallback to webapp content"). Admittedly, it seems that WARNing level is unnecessarily alarming. Sep 1 at 12:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.