1

we have created a new environment and installed CD 9.1 Services (deployer, discovery, session, and preview), and Updated all required configurations. IIS settings are configured the same as the old environment and we are able to view the website. But we are trying to Publishing content from CME to New Environment, we are getting Failed error on "Preparing Deployment".

we have followed the below steps to update the topology manager and config changes.

Updated New broker Database Details in "cd_storage_conf.xml" and "deployer_conf.xml".

for discovery register, executed below command on C:\microservices\discovery\config

java -jar discovery-registration.jar update

Updated New Discovery service using below command(s)

​Set-TtmCdEnvironment -Id DevelopmentStagingCD -DiscoveryEndpointUrl http://xxx:8082/discovery.svc

Sync-ttmcdenvironment –Id DevelopmentStagingCD

we missed any target type changes?

2
  • Have you set logback.xml to DEBUG and checked for errors?
    – Neil
    Sep 22 at 7:44
  • Yes, we enabled "Debug" mode for logback.xml and We did not find any errors on logs.
    – Chandana
    Sep 22 at 9:07
1

Failure to prepare for deployment often indicates a false Content Deployer configuration or problems with customizations.

If your publishing fails in the'Preparing for deployment' phase, try the following:

  • Is your Content Deployer configuration (deployer-conf.xml) correct?
  • Are you using a custom Module and/or Processor in your Content Deployer? The code for these customizations may be buggy. Consider removing them to see if deployment then works.
  • Is your Storage Layer configuration (cd_storage_conf.xml) correct? Note that other Content Delivery Web applications or services also have a cd_storage_conf.xml file, so make sure that the database in which published content is stored and from which it is retrieved is the same in those files.
  • Can you connect from your deployment system to the database(s) configured in the Storage Layer configuration? Test these connections using your database client.
  • Can you also double-check the add-on packages and deployer pipeline configurations if you are using add-on services
1
  • we are getting same error like below link (tridion.stackexchange.com/questions/20850/…) can you please provide Latest JAR Details. Error creating bean with name 'StorageManagerImpl' defined in URL [jar:file:/G:/microservices/deployer/services/deployer-sites-worker/udp-datalayer-11.1.0-1060.jar!/com/tridion/storage/management/StorageManagerImpl.class]: storageManagerTransactionMonitor': Unsatisfied dependency expressed through field 'transactionManager';
    – Chandana
    Sep 28 at 5:38
1

Now Publishing is working. Root cause is,

In the Tridion Site 9.1 installation media for the Deployer role there are now 9 deployer folders. The previous Deployer and Deployer-combined folders are now used to run with the add-ons framework. Pipelines are not enabled by default which causes the error. The quickinstall script or the documentation steps for a test environment requires the deployer-sites[-combined] role as illustrated in below screenshot. Do not use deployer-combined for Tridion Sites 9.1, this will not work as described in documentation link https://docs.sdl.com/LiveContent/content/en-US/SDL%20Tridion%20Sites-v2/GUID-DA9B138D-3710-424E-AEE7-9105556B33C9

Also, Refer https://gateway.sdl.com/apex/communityknowledge?articleName=000011717

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.