2

Trying to remote debug sites 9.1 workflow events.

After finally getting visual studio 2013 remote debugging connection to the Dev CMS Server from Amazon Workspace, I attached to the TcmWorkflowAgent.exe to debug my Workflow ActivityInstance Events. (As indicated in Debugging Content Manager https://docs.rws.com/783502/502913/sdl-tridion-sites-9-1/debugging-content-manager/procedure)

I have added the file path to the .pdb Debug | Options| Debugging | Symbols | Symbol file(.pdb) location

Adding a breakpoint we see a problem "The breakpoint will not currently be hit. No symbols have been loaded for this document."

Has anyone encountered this issue before or know how to resolve it?

I have googled for related articles but these relate to much older versions of Tridion.

SDL Tridion Event System Newbie Perspective by Alvin Reyes http://www.tridiondeveloper.com/sdl-tridion-event-system-newbie-perspective

Debugging a Tridion 2011 Event System

https://yatb.mitza.net/2012/03/debugging-tridion-2011-event-system.html

Remote Debugging in Visual Studio Made Easy(ish)

http://www.tridiondeveloper.com/remote-debugging-in-visual-studio-made-easyish

Getting Started with Tridion Event System !!

https://tridionwithanupam.wordpress.com/2015/07/08/get-started-with-tridion-event-system/

2

When Debugging, Attach to multiple processes. Although I want to catch the Workflow events (TcmWorkflowAgent process), you must also attach to IIS (w3wp process) for the breakpoint symbols to load.

1
  • Good background, Chris. I've heard someone mention "attach to all of them" before (perhaps from @MihaiC) but I didn't realize why. :-)
    – Alvin Reyes
    Sep 29 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.