2

In Tridion 2011 SP1, in the CME Component settings view, by accessing this view the Component is locked by default.

The issue is when I try to unlock a localized Component by clicking on the unlock button in this view, the unlock process starts but it never ends and no error raises.

Could it be related to the type of Component or if it is localized or not?

If this Component was pending at the end of a workflow (when I access to settings view), could the default Component lock operation become the reason of this issue?

update

Mainly I want to unlocalize a Component but if I enter into the Component this option is disabled. unlocalize a Component

To enable this option I do the following: I click on "Undo check-out" at Workflow tab of the settings of the Component.

Undo check-out

The "checking in item" operation takes long time and never ends the check-out. However this issue only occurs in some occasions.

enter image description here

Any suggestions are welcome.

Thanks in advance.

  • 1
    Can you be a bit more specific as to what your problem is, with unlock, do you mean undo checkout? also what is the Component settings view, perhaps you can add a screenshot of the view and indicate what you are trying to do there? – Bart Koopman Jul 17 '13 at 11:24
  • Mainly I want to unlocalize a component but if I enter into the component this option is disabled. link to image1 To enable this option I do the following:I click on "Undo check-out" at Workflow tab of the settings of the component.link to image2 The "checking in item" operation takes long time and never ends the check-out. However this issue only occurred in some occasions.link to image3 – Angela Gallardo Jul 18 '13 at 9:42
  • you can edit the question and add the images in there by pressing the image button, please also add the information in this comment to your question, it is much easier to read for people when you specify all relevant information in your question, rather than in the small print of a comment. – Bart Koopman Jul 18 '13 at 10:13
  • I have tried to add images, but when i click on "saved edits", in the page appears this message "You need at least 10 reputation to post images." and i can't save change. – Angela Gallardo Jul 18 '13 at 11:12
2

When you have the Component opened, the Undo Checkout option will have to first undo the checkout and then change the view (since the Component will no longer be editable). That is an action which will take a little longer, then when you would just try it in a folder/list view. Never the less, it should work, and because you mention it only occurs sometimes, I'm suspecting either your database or network.

Please ensure your database is well maintained (indexes and statistics regularly updated and transaction log truncated to keep small). Without this database timeouts can occur which might be the issue you are having.

Furthermore bypassing any problems you have, if you want to unlocalize a Component, then basically you are going to delete the local version. doing this from the opened item vie doesn't really make a lot of sense to me, as you are basically trying to delete the item in this view (so that it can be replaced with a view of the parent item). Try unlocalizing a Component from the list view. Just right click on the Component and select Unlocalize from the Blueprinting option menu. Then you also won't have to undo the checkout first.

Please note without proper database maintenance, an action like this will still be slow and can timeout.

| improve this answer | |
  • Thank you very much for your answer. I have tried unlocalizing a Component from the list view with right click (as you told me to do) , and works correctly. But I need to open the component, because I only have the unique identifier of the item (URI). To load the component view I add the URI to the search interface in the toolbar (adding It to the tail of the URL). link to image Can I do the same by other way without need to open the component view and by using only the URI of the Component? – Angela Gallardo Jul 19 '13 at 9:00
  • It is not impossible to unlocalize the item the way you tried to do it (I just found it a strange order of actions, but now I understand why you do it that way, since you only have the URI of the item), and agreed it is possibly faster this way than trying to figure out in which folder it is located. When your database is properly maintained, the undo checkout and unlocalize action shouldn't take much time. In my reference system it works fine to press the undo checkout button and then the unlocalize button, takes just a few milliseconds, so perhaps you should check the database maintenance – Bart Koopman Jul 19 '13 at 9:13
  • Thank you so much Bart for your excellent support with my issue. Now I can trace the solution with the data base people. Best regards. – Angela Gallardo Jul 19 '13 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.