8

I have two questions:

  1. What is the max size we can import?

  2. Can we increase Import size ?

I have already changed the below entry, but still no luck

requestLimits maxAllowedContentLength="209752100"  equals to 200MB

I am trying to upload a package of 950MB.

| improve this question | | | | |
  • Some Windows servers use a utility called URL Scan that also can be used to limit the size of HTTP requests. Check to see if that utility is running on your server. – Mr Smith Jul 19 '13 at 14:23
9

There are some guidelines for configuring Content Porter for first time use in the SDL Tridion Live Content document here (login required).

If you are using IIS 6 then you will need to change the metabase property called AspMaxRequestEntityAllowed

As Bart says, if you are using IIS 7 then you need to increase the maxAllowedContentLength attribute.

However, you may also need to increase the maxRequestLength attribute. More information on this can be found on the IIS.net Confusing required maxRequestLength and maxAllowedContentLength settings article.

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">         
    <system.web>
        <!-- This value is in **kilobytes** -->
        <!-- 512000 kilobytes = 500MB -->
        <httpRuntime executionTimeout="1200" maxRequestLength="512000" useFullyQualifiedRedirectUrl="false" minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100"/>
    </system.web>

    <system.webServer>
        <security>
        <requestFiltering>
            <!-- This is the value in **bytes** -->
            <!-- 524288000 bytes = 500MB -->
            <!-- The maximum for this is 4,294,967,295 (3.99GB) - http://stackoverflow.com/questions/4022434/-->
            <requestLimits maxAllowedContentLength="524288000" />
        </requestFiltering>
        </security>
    </system.webServer>    
</configuration>
| improve this answer | | | | |
5

The maximum size you can import is really depending on two factors, #1 the requestLimits set, and #2 your network. The latter is not something which you can really set, some packages are just too large to be handled in a reasonable way over some networks. This should not be a problem if your network is setup correctly, so lets focus on #1 for now.

You mention you want to upload a package of 950 MB, and you have set the maxAllowedContentLength to 200 MB, which means you specify in IIS that you will not allow anything larger than 200 MB, so indeed your Content Porter package of 950 MB is too large and will be denied.

Try setting the following in your web.config

<system.webServer>
  <security>
    <requestFiltering>
      <requestLimits maxAllowedContentLength="2147483648"/>
    </requestFiltering>
  </security>
</system.webServer>

This will allow for packages of 2 GB to be uploaded (so your 950 MB should be fine), please note that depending on your network, it might be slow as the packages get larger.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.