3

We have recently upgraded our Tridion environment from Web 8.5 to Tridion Sites 9.6. While Publishing old pages we are getting below error

Could not load file or assembly 'Tridion.Extensions.ContextExpressions.Common, Version=8.1.0.187, Culture=neutral, PublicKeyToken=ddfc895746e5ee6b' or one of its dependencies. The system cannot find the file specified.

Since the Context Expressions feature is discontinued now how to fix this error?

2
  • 1
    Do you actually need it? If it is discontinued, I guess it needs to be removed from your config.
    – Nuno Linhares
    Jun 1, 2023 at 14:04
  • can you please explain bit more detail which upgrade path you took? did you install it in the 8.5 setup did you upgrade to the same server? or a separate dedicated server you install the 9.5?
    – Velmurugan
    Jun 1, 2023 at 20:05

1 Answer 1

5

It is discontinued, and yes you should remove it. You are using it in the Default finish action Template building block. You need to reload the default template building blocks after the upgrade to 9.6. I had the same situation. Please follow this link:

Procedure

Start Template Builder by selecting Start > RWS Group > Template Builder from the Windows menu.

Select Tools > Create Default Building Blocks to load the default Template Building Blocks.

Select a location for the default Template Building Blocks and click OK.

https://docs.rws.com/986894/103312/tridion-sites-9-6-main-documentation/loading-template-building-blocks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.