1

We have upgraded the webapplication to DXA v2.2 from v1.8 and observed an issue related to ECL image embedded in RTF. When the image is embededded inside RTF field using ecl id we are getting a specific error while rendering the field in the webapplication. Sdl.Web.Common.DxaException: 'Unable to render Entity Model [xxx: 131921], because it has no MVC data.'

The RTF looks like: enter image description here This was working fine in the DXA1.8 and also I dont see this error if I add the full url of the ECL image. Also I dont get to see any error while previewing the component. Please suggest some solution to fix this.

3
  • Well done on the jump - that’s a big jump from 1.8 to 2.2. What have you tried and what were the results. When you say you try with the full url can you include an example to be more specific. Where is the source image and is it fair to assume there have been no changes in that system too. Aug 18, 2023 at 9:48
  • Please check the DXA R2 JSON rendered by CM (e.g. the result of previewing the Page/Component with the appropriate DXA TBB). If all is well, the MVC data is included in this DXA R2 JSON. This will tell you whether the problem is on CM-side or CD-side. Aug 21, 2023 at 11:57
  • @Dylan..MarkSaunders The resolved ecl image url which we are referring as full url. I have included two examples of ecl images added in rtf; one with ecl id and another with ecl image url. 1. ECL id used in RTF: <img src="ecl:19-dam-o2ffqxzr7b-damFile-file" style="width: 100%;"/> 2. Full url of ecl image used in RTF: <img src="dam.net/content/o2ffqxzr7b/jpeg/…" style="width: 100%;"/> Aug 31, 2023 at 8:15

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.