1

I am trying to upload a .net TBB assembly thorough the Visual Studio add-in. However, I am getting the following error:

Error: Error: Type mismatch

at[remote] Tridion.ContentManager.Templating.Assembly.TemplateAssemblyStorage.PerformStoreTemplateAssembly(...) at[remote] Tridion.ContentManager.Templating.WebService.AssemblyTemplateUploadWebService.PerformStoreTemplateAssembly(...) at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Tridion.ContentManager.Templating.UI.UploadAssembly.WebService.AssemblyTemplateUploadWebService.PerformStoreTemplateAssembly(Byte[] assemblyContents, Byte[] pdbContents, String assemblyFileName, String targetFolder) at Tridion.ContentManager.Templating.UI.UploadAssembly.AssemblyStorageClient.PerformStoreTemplateAssembly(String webServiceUrl, String userName, String password, String overrideFolder, Byte[] assemblyContents, Byte[] pdbContents, String assemblyFileName, Nullable`1 timeout) at Tridion.ContentManager.Templating.UI.UploadAssembly.AssemblyStorageClient.UploadAssembly(String assemblyPath) at Tridion.ContentManager.Templating.UI.UploadAssembly.AssemblyStorageClient.Main(String[] args)

Can anybody help me please?

  • Can be anything, but is usually happening when you have swapped namespaces or are referencing a namespace in another uploaded dll (like DD4T) which this DLL cannot access, or the template classes are not setup correctly (like using the [TcmTemplateTitle] annotation the wrong way). If you go into the Output window in VS, does it give more information? – Raimond Jul 31 '13 at 13:18
  • Thank you for your time, I have figured out the problem, issue was with folder id, I was setting "Publishing" root id tcm:0-20-1 but when I set "Template" folder id tcm:2-5-2, it started working. – Ali Jul 31 '13 at 23:44
  • 2
    Maybe you can explain this an answer to your own question then accept it for others to find? – Nuno Linhares Aug 16 '13 at 15:22
3

I have received this error when trying upload a DLL that did not have the needed reference DLLs in the GAC. Make sure that all DLLs needed by your namespace exist in the GAC of the server or are registered.

| improve this answer | |
1

As the documentation (requires login) mentions:

Run the TCMUploadAssembly command-line executable to upload a .NET assembly to the Content Manager. You can specify parameters to override configuration settings.

/folder:<tcmuri> Save the Template Building Block containing the .NET assembly to a Folder with the Content Manager URI (unique identifier) called <tcmuri>.

So you indeed have to supply the URI of a Folder, rather than the URI of a Publication. Which also clarifies your error message, Error: Type mismatch is correct as the type of a Publication is 1 and it expected the type of a Folder (being 2).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.