3

We are facing very weird issue. Staging and Prod have same no of records in the Broker and DBs are hosted on same physical machine and SQL server. Stage and Prod are on different CD servers.

Broker is queried using Broker APIs(CD), its working fine on all other environment including staging (which is having almost similar hardware and software) but on Production its performance is very slow. its taking 5-6 min to get results which on other environments takes seconds. it loads records between 20 - 150.

Has anybody faced this kind of issue and has some tips to resolve it?

  • Broker is queried using CoreService API ? Do you mean OData or Content web service ? CoreService is CMS web service and when you referred Broker it is on Content Delivery side and CoreService will not be in context. It will OData Service ( Content Delivery service).. Please update your question? First to check is DB Stats and indexes are up to date or not ? – Ram G Aug 7 '13 at 17:20
  • Its CD/broker API, sorry for mistake – Raj Kumar Aug 7 '13 at 17:28
  • I typically find performances differences are usually because of missed difference between environments (they're rarely identical). Assume nothing and be sure to check the same code is running in the environments (including any environment-specific identifiers like tcm-ids), storage configuration, additional non-Tridion applications on the servers, and the actual load. One peculiar scenario I've seen was a bad CD query on dev affecting a CM that shared the same database. "The last thing changed" is also good suspect. :-) – Alvin Reyes Aug 8 '13 at 18:22
4

I think there is a mistake in the concepts, the Broker database is not queried by the CoreService API, it is queried by the CD API / Content Delivery Web Service.

About your performance issue, I would recommend to perform standard maintenance tasks.

  • Reindex your production database.
  • Review your memory usage.
  • Perform profiling so that you can see which area is the bottle neck.
| improve this answer | |
  • its broker API/Cd API i have corrected it. – Raj Kumar Aug 7 '13 at 17:28
  • AS per DBA they have done the reindex and stats stuff. still they are analyzing it. – Raj Kumar Aug 7 '13 at 17:59
4

Having CCS enabled does not mean your cache is working correctly. Start by double-checking your bindings and making sure everything is turned on. This article is a great guide.

2nd, do try Eric Huiza's suggestion of running some basic database maintenance done on your broker database.

3rd, read the Tridion logs in DEBUG or TRACE level (if you have the patience for it). You can learn a lot about what's going on just by reading the logs.

4th - good luck.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.