6

I'm having problems UI-enabling a site upgraded from 2009 to 2011 SP1. We have the UI working, and Session Preview automatically publishing / updating, however when preview updates none of the CSS than is published from Tridion is rendered.

Using developer tools, I see every CSS file requested returns either a 500 response or a "resource interpreted as text/html" warning. This only happens when Session Preview is updated, or more specifically the page is being rendered in "PreviewDynamic" mode.

I've done the following:

  • Ensures that text/css mime-type is configured correctly on the session preview webservice.
  • Tried referencing external CSS (renders OK).
  • Tried copying a published CSS file to another location and referencing that one instead (renders OK).

The closest issue I can find is - Blocked CSS files for Session Preview only in Internet Explorer. I've tried all the steps here without any luck, also it happens in every browser (I'm mostly testing using Chrome).

Can anyone suggest anything? I'm about half an hour away from creating a "preview" sub-folder on the staging website and referencing files in there when in session preview :)

  • Have you added the HTTP module as described in the documentation (requires login) to the web.config of your staging website? Or in case you are using IIS6, you need to do even more (requires login) – Bart Koopman Aug 16 '13 at 8:24
  • Hi Bart, yes I'm including both the AmbientData and PreviewContent modules. – richeym Aug 16 '13 at 9:07
  • Sorry, I had the wrong link in that answer; I've updated it. Mainly putting the CMS url (and possibly staging's) in IE's Local Intranet zone fixed the issue for me. See the rest of the settings in Configuring your Web browser for Content Manager Explorer (requires login) to see if it's the same issue. – Alvin Reyes Aug 16 '13 at 10:58
  • Local Intranet zone made the site work in Compatibility Mode, I've updated the other question. The blocked CSS file weren't a problem in Chrome (Version 29.0.1547.57 m) for me though. – Alvin Reyes Aug 23 '13 at 19:06
1

By default, IE 10 blocks certain Session Preview files as a (cross-site) security precaution. I've seen this specifically for CSS, but it probably affects script and other files managed as Tridion pages.

I've been able to bypass this in IE using compatibility mode or by putting the CMS url into the Local Intranet zone, which will do the same thing. The documentation recommends setting IE even if using other browsers, probably since browser's share some settings.

See configuring your Web browser for Content Manager Explorer (requires login) for the details, which also includes the following.

Under Tools > Internet Options > Security tab > Local intranet zone > Sites > Advanced enable:

  • Run ActiveX controls and plug-ins
  • Script ActiveX controls marked safe for scripting
  • File downloads
  • Submit non-encrypted form data
  • Active scripting
  • Allow Programmatic clipboard access

Tip: in the Security Settings for Local Intranet zone, use keyboard shortcuts to quickly find each option (e.g. press R a few times to get to Run ActiveX...).

Also set encoding to Unicode (UTF-8) under View and Allow session cookies under Tools > Options > Privacy tab > Advanced > Override automatic cookie handling > Always allow session cookies.

If this doesn't work, it could indeed be a number of things that I tried in that question: Blocked CSS files for Session Preview only in Internet Explorer

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.