3

I have configured an IIS deployer and can access the httpupload.aspx page in browser. Logging says "Deployer Started" meaning the deployer is configured correctly.

When I publish my page through the Content Manager Explorer, it stays stuck on "Waiting for publish". Content publishing service is also running, with nothing logged in the event viewer, nor in Tridion logging file.

Can anybody help?

  • Have you tried restarting the publisher service? – Chris Summers Aug 20 '13 at 1:53
  • As mentioned in the given answers, known causes of an item being stuck in a "Waiting for Publish" status are a high publishing load or a Publisher service which is not started, if those appear not to be your issues, then it sounds to me like your Publisher service is not looking at the right queue. Can you edit your question and provide more details about your setup and configuration perhaps? – Bart Koopman Aug 20 '13 at 8:51
  • Just fixed my issue, problem was with java installation, I had 64 bit installed but things were not working, now i have installed 32 bit version as well and now all services are running and i can publish my pages. – Ali Aug 26 '13 at 3:05
2

This isn't necessarily a problem unless all queued items are "stuck."

See Locating where publishing fails (requires login) which explains Waiting for Publish means that the publish transaction is stuck (waiting would be more appropraite) in the Publisher Queue.

But the problem should resolve itself shortly. You may have lots of publishing requests queued or items.

Tips as a user:

  • Select show items to publish to see what's being queued
  • View items from all users; there may be other items in progress

Up to you if it makes sense to change an item's priority and/or remove other transactions to troubleshoot. Otherwise following the logs and looking at all the queued items should help you find the issue.

One point on the administrative side is to be careful assuming everything is correct, especially on new setups--be sure the IIS site, that httpupload, and even log files are the right ones matching your environment.

| improve this answer | |
2

This error is also common in Tridion 2011 when you have the publisher and the database server in the same machine. Transactions get stuck in Waiting for Publish status because the publisher started before the database service. It can be solved by configuring the Publisher Service to have a delayed start or by restarting it.

| improve this answer | |
  • I have only 1 page to upload and its my first page, so there are not too many transactions in the queue, I have restarted the system many time, restarted the publishing windows services but did not happen anything. – Ali Aug 20 '13 at 6:11
2

"Waiting for Publish" means that the job was submitted to the queue, but the publisher service didn't pick it up yet. On a busy system, this would mean that the publisher is busy with other jobs, but on a server without other jobs it indicates some sort of problem getting to the queue.

I would run the publisher service in debug mode and try to figure out what's wrong with it by reading the log information. To run the publisher in debug mode:

  • Stop the Publisher Service
  • Open a Command Prompt with a valid Tridion Administrator (ideally the user that performed the installation, or any other user with permissions to read the encrypted information in Tridion.ContentManager.Config - see Granting users access to encryption functionality - login required)
  • Change directory to [Tridion]\bin
  • Run TcmPublisher.exe /debug
| improve this answer | |
  • Just checked my "Publisher" windows service is not running, when i try to start it shows "Error 1068 The dependency service or group failed to start." – Ali Aug 21 '13 at 0:27
  • That means you have a problem with your install - probably wrong java version and transport service fails to start. If you have java 7 installed, remove it and install java 6 – Nuno Linhares Aug 21 '13 at 3:51
  • Just checked i had both version of java, I uninstalled version 7 and now i have "Java 6 update 26" transport service which is prerequisite of publishing service is not running, i checked the license files located at config folder of tridion installation folder, every thing is there, my iis deployer has exact same path of license file. – Ali Aug 22 '13 at 2:52
  • Tried to run TCMPublisher.exe /debug through command prompt, got huge list of errors on of them is "error calling method getdeploymentnotification of the object of cd_transport.transport" – Ali Aug 22 '13 at 3:27
  • I was getting the same error and the issue was with incorrect cd_license. The error can be seen in the log files cd_core – rdhaundiyal Sep 22 '16 at 4:42
0

Change log settings in logback.xml to DEBUG or TRACE and check TcmPublisher.log (or whatever you have specified the log file name to be). If nothing is being logged, you might want to check your configuration files.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.