7

I've encountered a weird issue where I cannot publish one page in the CMS. It always fails committing the deployment. Here's the error from the deployer log:

2013-03-05 23:06:45,805 WARN CommitPhase - Failed to commit: tcm:0-697751-66560 error: Unable to commit transactions, Commit failed for transaction: tcm:0-697751-66560, Commit failed for transaction: tcm:0-697751-66560 2013-03-05 23:06:45,805 WARN DeployPipelineExecutor - Phase: Deployment Commit Phase failure message: Commit failed for transaction: tcm:0-697751-66560, Unable to commit transactions, Commit failed for transaction: tcm:0-697751-66560, Commit failed for transaction: tcm:0-697751-66560, Unable to commit transactions, Commit failed for transaction: tcm:0-697751-66560, Commit failed for transaction: tcm:0-697751-66560 for transaction: tcm:0-697751-66560 2013-03-05 23:06:45,805 DEBUG DeployPipelineExecutor - Failure in Phase: Deployment Commit Phase attempt: 11 for transaction: tcm:0-697751-66560 2013-03-05 23:06:45,805 ERROR DeployPipelineExecutor - Final attempt in Phase: Deployment Commit Phase failed for transaction: tcm:0-697751-66560 2013-03-05 23:06:45,805 ERROR DeployPipelineExecutor - Original stacktrace for transaction: tcm:0-697751-66560 com.tridion.deployer.ProcessingException: Commit failed for transaction: tcm:0-697751-66560, Unable to commit transactions, Commit failed for transaction: tcm:0-697751-66560, Commit failed for transaction: tcm:0-697751-66560, Unable to commit transactions, Commit failed for transaction: tcm:0-697751-66560, Commit failed for transaction: tcm:0-697751-66560 at com.tridion.deployer.phases.CommitPhase.handleFailure(CommitPhase.java:100) ~[cd_deployer.jar:na] at com.tridion.deployer.phases.CommitPhase.execute(CommitPhase.java:84) ~[cd_deployer.jar:na] at com.tridion.deployer.phases.DeployPipelineExecutor.runMainExecutePhase(DeployPipelineExecutor.java:186) [cd_deployer.jar:na] at com.tridion.deployer.phases.DeployPipelineExecutor.doExecute(DeployPipelineExecutor.java:97) [cd_deployer.jar:na] at com.tridion.deployer.phases.DeployPipelineExecutor.execute(DeployPipelineExecutor.java:61) [cd_deployer.jar:na] at com.tridion.deployer.TransactionManager.handleDeployPackage(TransactionManager.java:80) [cd_deployer.jar:na] at com.tridion.deployer.queue.QueueLocationHandler$1.run(QueueLocationHandler.java:176) [cd_deployer.jar:na] at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [na:1.6.0_20] at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) [na:1.6.0_20] at java.util.concurrent.FutureTask.run(Unknown Source) [na:1.6.0_20] at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source) [na:1.6.0_20] at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.6.0_20] at java.lang.Thread.run(Unknown Source) [na:1.6.0_20]

The weird thing is, if I copy and paste the page in the CME, the copied page will publish. Of the two targets available (staging & live) this issue is only present on live.

Here's what I've tried:

  • Un-publishing the page from the CMS (all targets)
  • Republishing (it still publishes back to staging)
  • Changing the storage conf to not publish to the content delivery database and republish.
  • Delete the page from the CMS and reconfigure.

I'd appreciate any suggestions of things to try next.

Thanks

7

I think the most likely thing is that there are problems writing the file. So the first thing to check is file system permissions for the account that does your deployment. Don't forget to check that this is the account you think it is.

  • 1
    Thanks Dom, the issue was that the page on the server had some bizarre permissions so the deployer couldn't overwrite the file. Love you ! – johnwinter Mar 6 '13 at 15:54
  • Yes, bizarre. Maybe troubleshooting the page on the server caused the issue? – Alvin Reyes Mar 7 '13 at 1:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.