4

I am trying to publish some Pages but they end up failed every time. I checked the logs (event viewer/database/publisher) but have not found any indication. Same error happens when trying to preview the content of a Page. Please suggest

Following is the error sample:

(2147747185) Object reference not set to an instance of an object.
Unable to get rendered content of Page (tcm:15-12345-64).
Unable to retrieve rendered data from Page.

at Customer.TemplateBuildingBlocks.GetWebDavUris.Transform(Engine engine, Package package)
at Tridion.ContentManager.Templating.Assembly.AssemblyMediator.Transform(Engine engine, Template template, Package package)
at Tridion.ContentManager.Templating.Assembly.CSharpSourceCodeMediator.RunTemplate(Engine engine, Package package, String templateUri, String className)
at Tridion.Templating.CSharpTemplate.CSharpSourceTemplate.Transform(Engine __engine, Package __package)
at Tridion.ContentManager.Templating.Assembly.CSharpSourceCodeMediator.Transform(Engine engine, Template template, Package package)
at Tridion.ContentManager.Templating.Engine.ExecuteTemplate(Template template, Package package)
at Tridion.ContentManager.Templating.Engine.InvokeTemplate(Package package, TemplateInvocation templateInvocation, Template template)
at Tridion.ContentManager.Templating.Compound.CompoundTemplateMediator.Transform(Engine engine, Template templateToTransform, Package package)
at Tridion.ContentManager.Templating.Engine.ExecuteTemplate(Template template, Package package)
at Tridion.ContentManager.Templating.Engine.InvokeTemplate(Package package, TemplateInvocation templateInvocation, Template template)
at Tridion.ContentManager.Templating.Engine.TransformPackage(Template template, Package package)
at Tridion.ContentManager.Templating.Engine.TransformItem(Template template, IdentifiableObject itemToRender)
at Tridion.ContentManager.Templating.TemplatingRenderer.Render(ResolvedItem resolvedItem, PublishInstruction instruction, PublicationTarget target, RenderedItem renderedItem, RenderContext renderContext)
at Tridion.ContentManager.Publishing.Rendering.RenderEngine.Render(ResolvedItem resolvedItem, PublishInstruction instruction, PublicationTarget target, RenderContext context)
at Tridion.ContentManager.Publishing.Rendering.RenderEngine.Render(IdentifiableObject item, Template template, PublishInstruction instruction, PublicationTarget target, RenderContext context)
at Tridion.ContentManager.Publishing.Rendering.ComWrapper.RenderEngineFacade.RenderItemWithTemplate(IdentifiableObject item, Template template, String legacyRenderInstruction)
at Tridion.ContentManager.Publishing.Rendering.ComWrapper.RenderEngineFacade.RenderPage(UserContext userContext, String pageXml, String pageTemplateXml, String instruction)
UtilitiesPublish.RenderPage
Page.Render
Request.Render
  • 1
    Can you, instead of publishing, render the page with page template in Template Builder. This way you will be able to find if it's page or component presentations failing and which tbb is failing exactly – Andrey Marchuk Aug 22 '13 at 9:34
  • 1
    looking at the stack trace it is failing with an exception from the following TBB Ricoh.TemplateBuildingBlocks.GetWebDavUris in Transform method. There seems to be a null reference exception, you may want to post the TBB. – Likhan Aug 22 '13 at 9:51
  • 3
    It typically is quite helpful to run your TBB in the Visual Studio debugger. See these posts on StackOverflow: stackoverflow.com/a/12210982/209103 and stackoverflow.com/a/11366499/209103. – Frank van Puffelen Aug 22 '13 at 11:25
  • I have got same kind of error in previewing the page when I created a transaction object in a C# TBB, While preview of page transaction was not available to me, and reason of error was missing null check on transaction object. So look at the C# TBB code if using any. Second reason can be that, If you are using using template callable methods. If any issue in that code it can also be a reason for the errror. – AlokBhatt Aug 23 '13 at 4:18
3

As people have suggested in the comments, it may be an error inside your GetWebDavUris TBB. However, I've had experiences with 2009 where an error would occur for some strange reason (not related to my code) and a server reboot resolved it.

I suggest that before you spend any more time debugging this, restart the CM machine and try publishing again after.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.