12

I have noticed on a couple of environments that I use that the Experience Manager Footprint selection box is disabled on the Preview tab (it just contains the message 'There are no items in this view'). I have it enabled and showing the default on another environment, and as far as I know there was no configuration involved to get this showing. Any ideas why its not showing or how I can troubleshoot it further?

15

To have Footprint sets showing up in the Footprint Gallery in the Preview, you need to have your Staging website listed under "Website URLs" in the "Session Preview" tab of your Publication Target. You don't need to fill in an odata end point or any other field. Sometimes I make the mistake of specifying the website URL but then browsing my page through 'localhost' - which won't match up then.

  • Thanks Richard - glad that I dont have to enable session preview afterall... – Will Price Mar 7 '13 at 15:53
5

Check whether Session Preview is Enabled (see this post on how to enable/disable) It seems that Session Preview is required to use Footprints (although I am not sure why, as my understanding is that footprints just send a cookie to the staging website, where the ADF does its magic in overwriting claims based on the cookie values).

  • 1
    You don't need Session Preview as such -- see Richard's answer. – Peter Kjaer Mar 7 '13 at 15:28
  • Actually the Footprint buttons will stay enabled even when you disable Session Preview. I am not sure if this makes sense, I am assuming Session Preview is required for Footprints to work. – Jeroen Suurd Mar 7 '13 at 17:57
  • No, Footprint changes only need to reload the (CD) page to be reflected, no need to re-render the page on the CM – Nuno Linhares Mar 7 '13 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.