2

What are the browsers that are supported by Tridion 2011. I'm using Tridion 2011 and not the Tridion 2011 SP1.

5

The supported browsers for any SDL Tridion version are listed in the documentation under the topic Content Manager Explorer prerequisites (requires login).

For SDL Tridion 2011 GA, this is:

  • Microsoft Internet Explorer 7.0
  • Microsoft Internet Explorer 8.0
  • Mozilla Firefox 3.6
  • Google Chrome 8
  • Safari 4 for the Mac
  • Safari 5 for the Mac

If your browser version is not matching this list, the Content Manager Explorer may display a warning saying that your browser version is not supported. This doesn't always mean it will not work.

For Chrome and Firefox it usually means that newer versions work fine, with IE you might see unexpected results when using newer versions. Setting IE in Compatibility Mode might sometimes solve those (although that can also lead to more problems at times).

Therefore it is recommended to upgrade to the latest version of SDL Tridion always as that will have support for the latest browser versions (known at the time of the release of course). It also pays off to check the list of hotfixes, when a newer browser version is released which breaks the UI, hotfixes are usually created for that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.