6

I am trying to add users to Audience Manager from my webapp, and I am receiving the following error message.

2013-10-03 00:00:56,758 ERROR Contact - Unable to instantiate contact object com.tridion.configuration.ConfigurationException: Cannot find item type mapping in storage configuration: AudienceManagerProfile at com.tridion.marketingsolution.utilities.DatabaseType.fromStorageConfig(DatabaseType.java:23) ~[oe_utils.jar:na] at com.tridion.storage.AudienceManagerProfileDAO.isMSSQL(AudienceManagerProfileDAO.java:39) ~[oe_utils.jar:na] at com.tridion.marketingsolution.profile.ExtendedDetailsDal.getExtendedDetailsDal(ExtendedDetailsDal.java:23) ~[oe_profile.jar:na] at com.tridion.marketingsolution.profile.ExtendedDetails.loadExtendedDetailsTemplate(ExtendedDetails.java:40) ~[oe_profile.jar:na] at com.tridion.marketingsolution.profile.ExtendedDetails.(ExtendedDetails.java:78) ~[oe_profile.jar:na] at com.tridion.marketingsolution.profile.Contact.init(Contact.java:947) ~[oe_profile.jar:na] at com.tridion.marketingsolution.profile.Contact.(Contact.java:737) ~[oe_profile.jar:na]

As far as I can see my config is correct, what am I missing?

<StorageBindings>
  <Bundle src="preview_dao_bundle.xml"/>
  <Bundle src="AudienceManagerDAOBundle.xml"/>
</StorageBindings>
...
<Storage Id="profiledb" Class="com.tridion.storage.persistence.JPADAOFactory"
         Type="persistence" dialect="MSSQL">
  <Pool CheckoutTimeout="120" IdleTimeout="120" MonitorInterval="60" Size="5" Type="jdbc"/>
  <DataSource Class="com.microsoft.sqlserver.jdbc.SQLServerDataSource">
    <Property Name="serverName" Value="SERVER"/>
    <Property Name="portNumber" Value="1433"/>
    <Property Name="databaseName" Value="tridion_submgmt"/>
    <Property Name="user" Value="USERNAME"/>
    <Property Name="password" Value="PASSWORD"/>
  </DataSource>
</Storage>
...
<item typeMapping="AudienceManagerProfile" storageId="profiledb"/>
6

The <Item/> tag is supposed to be use a capital "i".

If you fix that, I'm guessing it will solve your problem :)

  • Damn! 20 plus item nodes and only one is lowercase... Thanks! – Chris Morgan Oct 3 '13 at 22:14
  • Been there, done that :) – Peter Kjaer Oct 4 '13 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.