I have a DD4T based website in Tridion 2011 SP1 using XPM.

When I update any content and click update preview it sometimes updates the preview with the new content and sometimes doesn't. Also it is showing the old contents in other edited regions after clicking U.P. which I had added yesterday. Please suggest. Earlier the preview was not at all working but after moving the ambient from <httpmodule> to <modules> in web.config fixed but seems it's not behaving perfectly.

I have checked the CP table in session preview db, the contents are getting added and cleared after exiting.

1 Answer 1


Session Preview cannot deal well with application caching, as that basically stops the page/application from requesting new content from the Broker (which session Preview would intersect and get from the Session preview DB).

By default DD4T has caching enabled, which basically stops it from working correctly right there. Now there is a certain level of caching which you can allow, but I keep forgetting the exact details. So check out this blog post from Albert Romkes, as he states in there, when trying to set it all up and figuring it all out, turn off caching...

  • I have tried adding <add key="CacheSettings_CallBackInterval" value="30"/> in web.config but there is no change.
    – user734
    Nov 4, 2013 at 11:41
  • @user734 That is not turning it off ;) Nov 4, 2013 at 13:00
  • No, everytime it shows the old contents on 'Update preview' after refreshing though I didn't change those components today. And the components which I edit sometime works and not on UP. By setting the above in config I thought it would bring from broker after 30 secs but it's not working and I am not sure from where the old contents changed 3 days back are coming.
    – user734
    Nov 4, 2013 at 14:05
  • @user734 my guess is that that is coming from DD4T application caching, but I can't say for sure of course Nov 4, 2013 at 15:04
  • How can I atleast clear that cache for a fresh check.
    – user734
    Nov 4, 2013 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.