We are using SDL Tridion 2011 SP1 wih XPM. Once we create the page from XPM UI after giving its location and clicking 'Create Page' in the dialog, it says

Object reference not set

Here is the stack trace... Please suggest.

at Tridion.Web.UI.Models.SiteEdit.Services.GetPublicationTargetMatchInfoFromWebsite‌​Url(String publicationTargetId, String url, SessionAwareCoreServiceClient client) 
at Tridion.Web.UI.Models.SiteEdit.Services.GetPublicationTargetMatchInfoFromWebsite‌​Url(String publicationTargetId, String url)
  • It looks like SessionAwareCoreServiceClient client is passing as null. at Tridion.Web.UI.Models.SiteEdit.Services.GetPublicationTargetMatchInfoFromWebsite ​Url(String publicationTargetId, String url, SessionAwareCoreServiceClient client) Better you need to post full stacktrace. Commented Nov 11, 2013 at 16:16

1 Answer 1


Judging from the stack trace, I'm guessing you haven't filled in the settings on the relevant Publication Target ("Session Preview" tab).

Obviously, you should have received an error message telling you as much - but perhaps there was a problem with that in 2011 SP1.

  • I have tested on other systems in my team and this error is only appearing for me. Checked the Event Viewer log and only warnings are there and not errors. Please guide.
    – user734
    Commented Nov 12, 2013 at 9:47
  • Do you mean you have tested it from other client machines, connecting to the same Experience Manager and the same URL? Commented Nov 12, 2013 at 12:32
  • Yes we have tested the same URL using the same XPM from other machine and it works for them but not me.
    – user734
    Commented Nov 12, 2013 at 13:34
  • Well then something's likely different between the two machines. :-) Check browser, browser versions (and settings), and maybe user authorization. For example, do you both have scope and permissions to the context publication and structure group (though I'd expect more of an authorization error)? Browser settings also really matter for XPM. Commented Nov 15, 2013 at 5:39
  • Also, if you haven't already cleared your browser cache - now would be a good time :) Maybe it's caching a reference to a different Publication target. Commented Nov 15, 2013 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.