3

We were doing some content entry and suddenly we see that one of component gave errors in saving. Now, the component is showing as locked in the CME. If we now try to do Open or CheckIn or Undo Checkout the component, we get errors as shown below:

enter image description here

What I have already tried so far:

  • Tried check in, undo checkout, re-open but all ends up with error; also the Rollback option is being shown as "disabled"
  • No Error or Warning is there in the Event Logs
  • If we open any other component (even based on the same schema), it is opening without any issue. Other operations like Saving, check out, check in etc. are also working fine
  • This erroneous component was opening correctly few days ago
  • There does exists a Event DLL but have verified that neither it has got changed in recent time, nor there is any suspicious text that may cause such issue
  • Could not check anything in CM DB as do not have access to it

Did anyone faced similar issue before and can suggest any thing else that can be checked for the root cause

  • What does the history of the Component say, has it been changed recently, and who did the last change on it (system, admin or regular user)? – Bart Koopman Nov 14 '13 at 11:20
  • a System Admin has done the changes recently, and with the same user (System Admin), we are trying to open/checkin the component – Pankaj Gaur Nov 14 '13 at 11:27
  • 2
    From the looks of the error I would think there is some invalid content in there, somehow. Sounds like a pretty serious issue, I would recommend to contact Customer Support. Or for a quick solution, revert to a database backup from when this item was still working, but you should report the issue never the less, so keep a DB backup of today for CS. – Bart Koopman Nov 14 '13 at 11:30
  • No Schema changes done in the past few days btw? – Bart Koopman Nov 14 '13 at 11:32
  • No recent Schema change as well :( – Pankaj Gaur Nov 14 '13 at 11:42
3

Could not get much breakthrough in it. Got information from DB that the content is stale ("How" is still a mystery for me as per my knowledge it should not even got saved). The option left to me is updating in DB but that's really I never wanted to go nor I would recommend it to anybody. I tried restarting all the services and DCOM+ as a blind guess, it did not resolves the issue (Could not open the component) but surprisingly, it was shown as checked in and Delete option was enabled. I deleted the component and created afresh with correct content and it works without any issue

| improve this answer | |
2

Did the content author edit the source of the component, instead of the source of a rich text field? If a content author copies and pastes into the source of the component, I've gotten this error before.

Can you review the history of the component, roll it back to an earlier version, and save?

If there's a point in the component's history that you can roll it back to - then that's the indicator that the issue is with content somewhere.

| improve this answer | |
  • I am not sure but there might be a possibility that the content author might have done that, however, as I have already stated in my question, we were not able to roll back the component as the option comes disabled. – Pankaj Gaur Nov 18 '13 at 16:09
  • even if you can't actually roll back to an earlier state, are you able to copy and paste all of the source from version 1 into a brand new version? – paceaux Nov 18 '13 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.