8

If I click on a component in Experience Manager and select the Layout tab, I see a list of component templates linked to the component schema. Unfortunately, I have a lot of system Component Templates which are not for editorial use (they are dynamic and are not allowed to be used to put components on pages), but which appear and are selectable in the Layout tab . If I select one, I even get an error, and then cannot switch back or do anything else until I click Cancel Editing:

Invalid value for property 'ComponentPresentations'. A dynamic Component Template you have selected is not allowed on a Page. Unable to save item

I would not expect these CTs to appear (they would not appear when editing the page in the CME) , so is there some configuration I have missed, or is this a bug?

  • Your DCTs definitely don't have "allow on page using dynamic assembly" checked? – Rob Stevenson-Leggett Nov 20 '13 at 10:51
  • Definately - otherwise I would not get that fairly clear error message either I guess! – Will Price Nov 20 '13 at 11:43
  • :P Just checking! Sounds like on for Support to me. – Rob Stevenson-Leggett Nov 20 '13 at 11:56
  • I have raised a ticket... will update when I hear more – Will Price Nov 20 '13 at 14:29
  • Good find. Would hiding them via permissions work? I've seen requests to "configure" the CTs and/or PTs in XPM. This would make a good SDL Tridion Idea if it's expected current behavior (I'm thinking the error means it might be). – Alvin Reyes Nov 21 '13 at 2:07
3

This requires hotfix CME_2013.0.0.87205. The hotfix was originally issued for 2013 GA, and didn't make it into 2013 SP1, however I have tested the hotfix on SP1 and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.