3

Wanted to share a simple but interesting issue that I have faced recently

Scenario:

In SDL Tridion 2011 SP1, I have Component- Component A which have two multimedia link field. Two .png images - GraphStats1&2.png and GraphStats2013.png are associated in these multimedia link field of Component A.

This component is then placed on the Page A with a static component template CT_A.

Issues & Observations:

If we publish Page A, it successfully get publish and all the data of Component A get renders correctly except the image (GraphStats1&2.png). The image GraphStats2013.png, however, get displayed correctly

Even if we try to Preview the Page A, all data except the image GraphStats1&2.png appears correctly. Even the image GraphStats2013.png.

If we change the Component A to have same multimedia containing image GraphStats2013.png at both places, then it get appear at both place. On the other hands if Component A is changed to have same multimedia containing image GraphStats1&2.png, then the image does not appear at any of the place

  • Can you share some details of the setup, specifically OS of the Deployer and Presentation Server, Web Server type/brand and configuration of your encoding (Publication Target and file-encoding of the Java processes on the Deployer and Presentation Server)? – Bart Koopman Nov 22 '13 at 10:28
  • I think the deployer and presentation server or even the whole content delivery side does not matter as the issue is there even if we preview the page. Please also read my answer as well. I just wanted to share the thing as the issue is already resolved – Pankaj Gaur Nov 22 '13 at 10:33
  • 1
    You might have a point there indeed, then I'm just wondering if it might be a 2011 issue only. On my 2013 image an image with an & gets resolved just fine, also in preview (showing <img src="/Preview/Images/GraphStats1%262.jpg"/>), but if your webserver can't handle that well, then you could simply disallow the & in image filenames or replace the outcome of %26 back to & in your template. – Bart Koopman Nov 22 '13 at 11:00
  • For sure it is with SDL Tridion 2011 – Pankaj Gaur Nov 22 '13 at 11:03
3

Solution

The problem was with the use of special character in the image name - i.e. the character "&" in the image file name GraphStats1&2.png, if the name is changed to not have "&" in it (say GraphStats1_2.png), the issue got resolved. The real thing is that there is no error message appear anywhere - neither during saving, nor during publishing.

The issue was very small and could have been caught if multimedia components were created manually based on proper naming conventions or in fact if the images are being created at our end with proper namings.

However, we are getting a number of images in bulk from the client and using webdav to put them in the Tridion system, so it was difficult to identify.

Please share if there could be any other configuration/setting issue somewhere which may be causing this behaviour

| improve this answer | |
0

Few special characters have issues while we have them as part of the File Name, below are the list of Characters which have the issue:

< & > # % * : | ~ +

Kindly check the below URL to find a solution for your Specific special Character “&”

http://support.microsoft.com/kb/826437/en-us

http://sdllivecontent.sdl.com/LiveContent/content/en-US/SDL_Tridion_2011_SPONE/piw_concept_75E167C928AE4E0E86FF9DDE70A6D057 (requires login)

| improve this answer | |
  • The intention of sharing the question is that of sharing the knowledge as I have already faced and resolved this issue. – Pankaj Gaur Nov 22 '13 at 16:26
  • Thanks that you have shared few links and may be useful for someone else, but none of the above article address the scenario mentioned in the question. The MS KB is 6-7 years older and applies to ASP.NET 1.1. Moreover the SDL Live Content address the issue with webdav (which is basically again issue with MS and not SDL Tridion). In fact it specifies a resolution as using CME instead of Webdav. – Pankaj Gaur Nov 22 '13 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.