4

We are using ADAM as our assets repository and have installed Tridion ADAM connector. By default the max content length came as 200MB but now i am trying to increase it size to around 400MB in ExternalContentLibrary.config file and got the below error. Am I missing something?

An error occurred while trying to resolve URI: ecl:1xxx-xxx.ecl One or more errors occurred. One or more errors occurred. The value of this argument must be non-negative. Parameter name: value Actual value was -939524096.

Component: Tridion.ContentManager.Publishing Errorcode: 0 User: xxxx

StackTrace Information Details:

Server stack trace: at System.ServiceModel.Channels.TransportBindingElement.set_MaxBufferPoolSize(Int64 value) at Tridion.Ecl.Adam.Api.AdamConnector.GetNewSamlClient()
at Tridion.Ecl.Adam.Mountpoint..ctor(IEclSession session) at Tridion.Ecl.Adam.Provider.CreateContext(IEclSession session) at Tridion.ExternalContentLibrary.AddInPipeline.V2.AddInSideAdapters.ContentLibraryViewToContractAddInAdapter.CreateContext(IEclSessionContract session) at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs) at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

  • Interesting question. The documentation sdllivecontent.sdl.com/LiveContent/content/en-US/… does not mention a maximum on the content lenght. You filled in 400 as the value in the config is in MBs right? What if you change it back to 200, just to check if there is nothing else which fell over. And just guessing here, but do you exceed any other limits in Tridion configuration files? – Jan H Nov 27 '13 at 9:13
  • Yes i was filling 400 as the value which is in MB. When changed back to 200 it is working. I have also checked the deployer config file which has 500Mb as the limit and I couldn't see any other Tridion limits being exceeded. – Guest19876 Nov 27 '13 at 9:40
5

Unfortunately, the max value for this setting is 255.

To increase this maximum a hotfix is needed.

| improve this answer | |
  • And to request hotfixes you should contact your friendly Customer Support rep... – Nuno Linhares Nov 27 '13 at 17:05
  • 1
    Thanks for the answer as i was banging my head finding the place defining the limit. Would have been easy if this was mentioned in documentation :( – Guest19876 Nov 28 '13 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.