3

Publishing fails when handling large binaries.

I see that we can increase size limit of binary files here.

Will this solve my issue.

  • 3
    Why not you try yourself and see if it works and in case you still see issue, post it back with more detail and your research – Pankaj Gaur Dec 5 '13 at 9:42
  • Your question is way too vague. Provide system details, version numbers and logs. – Nickoli Roussakov Dec 5 '13 at 12:36
  • Looking at your comment within Harold's answer, it is unclear whether this question is regarding saving large binary files, or publishing large binary files. @Patan - Can you please clarify? – Jonathan Williams Dec 11 '13 at 14:16
9

That link you refer to has nothing to do with publishing, but with uploading files into the CM I assume you use the http(s) deploy method for publishing files. In that case, you should go to the web.config of your website where your httpupload.aspx file is hosted (that file is responsible for receiving the publish packages from your CM).

The web.config should contain these settings

<system.web>        
  <httpRuntime maxRequestLength="4096000" executionTimeout="300" />
</system.web>
<system.webServer>
  <security>
    <requestFiltering>
       <requestLimits maxAllowedContentLength="4096000000" />
     </requestFiltering>
  </security>
 <system.webServer>

I believe the system.webserver setting is required when you are on IIS7 or higher (also note this value is in bytes, while the system.web setting value is in kilobytes).

Note that, if you would be publishing extremely huge files, there might still be some transport issues or timeouts, depending on your connection settings. But, these settings will help you in most circumstances

| improve this answer | |
  • Thank you for the answer. Can you tell me if it is applicable to IIS 6 also. – Patan Dec 5 '13 at 9:57
  • yes, the system.web setting (httpruntime...) is applicable for iis6. the system.webserver setting is applicable for iis 7 – Harald Hoffelinck Dec 5 '13 at 9:58
  • I implemented it. changed to 200MB. But I am getting transaction has aborted and unable to save the component. Uploading of component is success but saving fails. – Patan Dec 5 '13 at 10:46
  • 1
    could you please add some log files (maybe it's better to start a new question, it might be unrelated) – Harald Hoffelinck Dec 5 '13 at 10:59
  • 1
    Don't forget the MaxSize property in the cd_deployer_conf.xml from the HttpUploader website! – Albert Romkes Dec 5 '13 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.