5

I am getting a 400 bad request when I try to use the Session Preview functionality in Tridion 2013 SP1. The exception details are below, any help is much appreciated.

com.tridion.webservices.QueryException: Property 'batch' cannot be requested, there was no resource selected
    at com.tridion.webservices.odata.input.ODataInputParser.checkEntityInput(ODataInputParser.java:60) ~[cd_odata.jar:na]
    at com.tridion.webservices.odata.input.ODataInputParser.parse(ODataInputParser.java:37) ~[cd_odata.jar:na]
    at com.tridion.webservices.odata.input.handler.ODataWebserviceHandler.insertODataEntity(ODataWebserviceHandler.java:315) ~[cd_odata.jar:na]
2
  • Are you getting that on every Page, even an empty Page for example (without Component Presentations), or can it be related to something specific on that Page? Also is this a new installation of SDL Tridion 2013 SP1, or an upgrade, and in that case, has the Session preview worked before the upgrade? – Bart Koopman Dec 12 '13 at 14:05
  • Hi Bart, it is a new installation, the oData endpoint is working for read operations, however, it seems that it doesn't recognize /odata.svc/$batch – Eric Huiza Dec 12 '13 at 15:00
1

Did you find a solution to this?

I upgraded from Tridion 2013 to 2013 SP1 earlier this week and also had trouble with the Session Preview Webservice.

I cannot remember the exact message that I was getting, but your 'batch' issue does sound familiar.

Although it may not satiate your appetite for knowing the exact cause of your issue, I fixed the problem within my upgrade by replacing all of the JAR, DLL and Webservice files in my Session Preview webservice folder with those supplied in the (.NET) installation example, and it just worked.

  • [Tridion 2013 SP1 Installation Files]/Content Delivery/roles/preview/webservice/dotNET/webapp/x86_64

It is worth noting that the Content Delivery JAR file reference page within the online documentation (login required) suggests that you do not need cd_deployer.jar within your lib folder for the . This didn't seem to be the case, and I was getting an error saying that com.tridion.deployer couldn't be found when I tried to browse to the service directly.

1
  • Interesting. I think cd_deployer is needed to cater for tcdl transformation after you update preview. I'll check the doc. – Nuno Linhares Jul 8 '14 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.