7

I'm running Tridion 2011 SP1 & having an issue getting Tridion UI 2012 to work correctly.

Simply - when I navigate to a URL that should return a 404 (non-existent directories or files), it doesn't return a 404 - instead, the directories are automatically created.

We recently applied hotfix CD_2011.1.1.82378 that prevents this behaviour on specific url paths (you add paths that should be ignored by Tridion UI to an 'excludedpaths' node in the cd_ambientconf.xml file), however for obvious reasons this will not work for paths that should return a 404.

Has anyone experienced this / know the solution?

  • Is it a ASP.NET website on IIS or a JSP website and if so what application server? I think I remember having this issue on IIS when my web.config didn't contain the Tridion.ContentDelivery.Preview.Web.PreviewContentModule httpModule. – Bart Koopman Jan 8 '14 at 16:02
  • ASP.NET website on IIS. I spoke with SDL in the end - this is expected behaviour unfortunately. – Jamie Jan 13 '14 at 21:39
  • Do we have a fix for this in 2013 SP1?? I am experiencing the same behaviour in 2013 SP1 Preview site. Please suggest. – Saurabh Mehndiratta Nov 21 '14 at 17:06
1

Turns out this is expected behaviour.

It is assumed Experience Manager will never be enabled on a live site, and so this issue will only arise in development or staging environments.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.