7

On my dev environments I am running multiple instances of Tridion Content Delivery in the same Tomcat (JVM) server. Typically I have:

  • 2x Tridion Deployer
  • 1x OData Web Service
  • 2 or 4x Tridion Content Delivery (websites)

By the time the 3rd or 4th instance of Tridion starts I start getting Permgen space errors. My server has enough memory available, how can I increase the amount of memory used by Tomcat?

  • I think even as per the FAQ this is very much desirable to ask question to which you know answer and come across multiple options. +1 for sharing nice question (and answer (by Eric)) – Pankaj Gaur Jan 10 '14 at 6:23
6

I think the best way to do it is by updating the Catalina.bat file to increase the Heap Size in the java ops.

set JAVA_OPTS=-Xms1024m -Xmx1024m -XX:PermSize=256m  -XX:MaxPermSize=512m 
| improve this answer | |
  • I was going to answer that you can add this to the Tomcat startup options (pretty much the same you're saying with Catalina.bat). Thanks – Nuno Linhares Jan 9 '14 at 15:35
  • Is there a way to see what options were originally used? – Elena Serghie Mar 5 '14 at 19:40
2

The best way to set these parameters is creating a file called setenv.bat (Windows) or setenv.sh (Linux) and place it in the Tomcat bin directory. you can put here the variables JAVA_OPTS or CATALINA_OPTS, I prefer setting CATALINA_OPTS because these varaible affects only Tomcat, not for other Java applications.

set CATALINA_OPTS="-Xms1024m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=512m" (windows)

export CATALINA_OPTS="$CATALINA_OPTS -Xms1024m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=512m" (Linux)

Hope this hepls

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.