5

I have a problem with 2011 version. There are few components marked with a little lock and I can´t figure out how to unlock it. I am afraid that it was locked by a person, who is no longer in my company.

printscreen

I need to edit the content of these components at 05C. I have tried to use the "check-out" and "undo check-out" buttons, but nothing really changed.

How can I unlock it?

  • 1
    You'll probably need a user with Administration privileges to unlock the component through the CME. Failing that, they can be checked-in via the Core Service API. – NVanderEnde Jan 10 '14 at 11:50
  • I think the file is opened by some user. When an item is opened by a user it shows lock icon. – Ajo Mathew Jan 10 '14 at 12:30
  • 1
    I changed "folders" to "components," which I'm pretty sure is what you meant. – Alvin Reyes Jan 10 '14 at 23:09
  • Also consider voting for this idea to give certain non-admins some ability to check-in items they don't own: ideas.sdltridion.com/ideas/detail.asp?i=1587. – Alvin Reyes Jan 10 '14 at 23:10
10

Open the item and check the "Locked by" section on the Info tab. Then contact that person.

If it's a system account, the item is likely locked by workflow and needs to go through the workflow process to unlock.

If it's locked by a person who no longer works there, you'll need a Tridion Administrator to unlock the item for you.

| improve this answer | |
-2

You can do the same using database query if you have acsess to tridion CM database

update ITEM_REFERENCE_PUBLICATIONS set ITEM_LOCK=0,ITEM_LOCK_DATE=null,ITEM_LOCK_OWNER=null    where ITEM_LOCK=1  and ITEM_REFERENCE_ID=19882
| improve this answer | |
  • 1
    Executing queries directly on the DB is not supported. – Albert Romkes Jan 11 '14 at 21:57
  • That is true that running Queries directly on DB is not Supported. But sometimes you don't have option other than this. Here we are talking in terms of a developer not a Content Editor, So I think one should know all the ways of to resolve a problem. – AlokBhatt Jan 12 '14 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.