1

We have a size problem with our catalina.out.

We are configuring the logging.properties file and the log4j.properties files. We are setting all of the log levels to WARNING or ERROR, but in catalina.out we still see DEBUG entries.

Here is an example of some of the Deubg statements that we are seeing:

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - ComponentLink Found metadata for page: 79121

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - ComponentLink.getLink(): start retrieving pathinfo for this page: 79121

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - ComponentLink.getLink(): componentLinkInfo.getPageId()<>sourcePageId=81284=79121

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - Path to source page is: /cat/_include

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - Path to found page is :/cat/pagines-finals

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - Score found is 101

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - Found component with score 101

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - ComponentLink.getLink(): found a target page, using PageLink to link to page: 81284

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.ComponentLink - ComponentLink.getLink(): Anchor: null

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.PageLink - PageLink.getLink(...) called to resolve link for page: 81284

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.PageLink - PageLink.getLink(...) got URL from PageMetaData: /cat/pagines-finals/notes-legals.jsp

14:08:16.644 [TP-Processor1] DEBUG com.tridion.linking.PageLink - PageLink.getLink(...) returning link:

Snippet code from our logging.properties: ...

com.tridion.linking.ComponentLink.level = WARNING 
com.tridion.linking.PageLink.level = WARNING

...

Snippet code from our log4j.properties:

...

log4j.rootLogger=ERROR, FileAppender
log4j.appender.FileAppender=org.apache.log4j.RollingFileAppender
log4j.appender.FileAppender.File=/usr/share/tomcat6/logs/web.log
log4j.appender.FileAppender.MaxFileSize=1MB
log4j.appender.FileAppender.MaxBackupIndex=1
log4j.appender.FileAppender.layout=org.apache.log4j.PatternLayout
log4j.appender.FileAppender.layout.ConversionPattern= %d %-5p: %m%n

...

This makes our file sprocket grow significantly every day.

How can we change the logging settings so that we only see warning errors (or above)?

Thanks

3

I think you have to change that setting in the logback.xml file available in your application classes folder.

<property name="log.level" value="WARN"/>
| improve this answer | |
4

No need to change the log level on log4j.properties and logging.properties.

As @Eric mentioned, you need to update log level on logback.xml

Sample Logback file looks like,

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <!-- Properties -->
    ...
    ...
    <property name="log.folder" value="c:/tridion/log"/>
    <property name="log.level" value="ERROR"/>
    ...
    ...
    ...
    ...
</configuration>

List of Log Levels:

  • ALL
    • The ALL is used to turn on all logging.
  • DEBUG
    • The DEBUG level designates informational events of lower importance.
  • ERROR
    • The ERROR level designates error events which may or not be fatal to the application.
  • INFO
    • The INFO level designates informational messages highlighting overall progress of the application.
  • OFF
    • The OFF is used to turn off logging.
  • TRACE
    • The TRACE level designates informational events of very low importance.
  • WARN
    • The WARN level designates potentially harmful situations.
| improve this answer | |
2

Apart from the info given in the other answers, you can also disable linking logging completely by adding the following logger in logback.xml:

<logger name="com.tridion.linking" level="OFF">
    <appender-ref ref="rollingCoreLog"/>
</logger>

Turning logging completely off is of course not very handy, in case errors occur when links are resolved. Setting the level to ERROR or WARNon live environments and to DEBUG on development environments is what I always do.

| improve this answer | |
1

Solved.

We deployed the logback.xml file in wrong place.

Thanks to all.

| improve this answer | |
0

Our logback.xml file was already set to ERROR.

    <property name="log.pattern" value="%date %-5level %logger{0} - %message%n"/>
<property name="log.history" value="7"/>
<property name="log.folder" value="/data/tridion/log"/>
<property name="log.level" value="ERROR"/>
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.