0

When I use Template builder and I try to debug a component template, I always get the following error:

System.Web.Services.Protocols.SoapException: Cannot use this process, it has exited

and

System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)

and

System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

and

Tridion.ContentManager.Templating.CompoundTemplates.DomainModel.Proxy.CompoundTemplateWebService.StartDebuggingWithItemUri(String compoundTemplateId, String compoundTemplateXml, String itemId, Boolean includeSystemLog, TraceEventType logLevel)

and

Tridion.ContentManager.Templating.CompoundTemplates.DomainModel.DebugObject.Start(Template template, Object debugItem, LoggingOptions loggingOptions)

I've checked Event Viewer:

Cannot use this process, it has exited

Component: CompoundTemplateWebService Errorcode: 0 User: NT AUTHORITY\NETWORK SERVICE

StackTrace Information Details:

Server stack trace: at Tridion.ContentManager.Templating.Debugging.DebuggerRemoteRunner.Ping() at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs) at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)

What can be the problem?

  • Can you give a bit more context around the problem, for starters what version of SDL Tridion are we talking about and does this happen on any template or on a specific template, and in case of the latter, what is happening in that specific template exactly? – Bart Koopman Feb 6 '14 at 12:39
  • I'm using Tridion 2013 and the problem happens in all the templates. – Aroma Feb 6 '14 at 13:53
  • You mention debugging, so what process did you connect to in Visual Studio? or is it already happening when yuo simply run a Template in the template Builder? – Bart Koopman Feb 6 '14 at 14:06
  • Please post what worked (and even accept) if you were able to fix this SOAP issue for Network Service for Template Builder. – Alvin Reyes Aug 6 '14 at 5:56
1

This error appears when you run template builder because similar I faced last time when templating webservice was down, we found and fixed by doing below task:

Only I have selected "Ignore client certificate" from Secure communication section under Directory security tab and found start working.

enter image description here

Error was:

The request failed with HTTP status 403: Forbidden. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Tridion.ContentManager.Templating.CompoundTemplates.DomainModel.Proxy.CompoundTemplateWebService.Login(Boolean initData) at Tridion.ContentManager.Templating.CompoundTemplates.DomainModel.Model.Login(Uri contentManager, ICredentials credentials) at Tridion.ContentManager.UI.CompoundTemplateDesigner.DesignerForm.LogonAs(Uri uri, Exception initialError)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.