7

I am getting 404 error when edit the page content using XPM and click finish editing. I gone through some articles to place se_blank.html in root folder of website and done that too but still facing the same issue.

Here is the event log detail -

Event code: 4011 
Event message: An unhandled access exception has occurred. 
Event time: 11/02/2014 12:48:31 
Event time (UTC): 11/02/2014 12:48:31 
Event ID: cf283bf1c893410fb6cdc9e2e4993af4 
Event sequence: 49 
Event occurrence: 3 
Event detail code: 0 

Application information: 
    Application domain: /LM/W3SVC/3/ROOT-1-130365954232441607 
    Trust level: Full 
    Application Virtual Path: / 
    Application Path: D:\websites\LiveHTTPUploadDB\ 
    Machine name: GHJHDURD34 

Process information: 
    Process ID: 3956 
    Process name: w3wp.exe 
    Account name: IIS APPPOOL\HTTP Upload (dbTridion) 

Request information: 
    Request URL: http://GHJHDURD34:82/httpupload.aspx?fileName=tcm_0-5873-66560.state.xml&action=remove 
    Request path: /httpupload.aspx 
    User host address: 10.4.114.5 
    User: APP4\admmts 
    Is authenticated: True 
    Authentication Type: Basic 
    Thread account name: IIS APPPOOL\HTTP Upload (dbTridion) 

Here is what i get in cd_core, cd_deployer logs -

2014-02-12 15:07:09,561 DEBUG TransactionLocationHandler - State file found for transactionId: tcm:0-5877-66560 checking if ready for commit/rollback
2014-02-12 15:07:09,564 DEBUG TransactionLocationHandler - Received commit package, we are ready for transaction: tcm:0-5877-66560
2014-02-12 15:07:09,564 INFO  QueueLocationHandler - Retrieved Deployment package from queue with transactionId: tcm:0-5877-66560 and type: PREPARE
2014-02-12 15:07:09,702 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:09,804 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:09,905 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,007 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,108 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,210 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,330 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,433 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,535 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,638 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,741 WARN  DeployPipelineExecutor - Phase: Deployment Prepare Commit Phase failure message: Could not find the Transaction record for: tcm:0-5877-66560 for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,741 ERROR DeployPipelineExecutor - Final attempt in Phase: Deployment Prepare Commit Phase failed for transaction: tcm:0-5877-66560
2014-02-12 15:07:10,742 ERROR DeployPipelineExecutor - Original stacktrace for transaction: tcm:0-5877-66560
com.tridion.deployer.ProcessingException: Could not find the Transaction record for: tcm:0-5877-66560
    at com.tridion.deployer.model.transaction.TransactionPersistence.load(TransactionPersistence.java:74) ~[cd_model.jar:na]
    at com.tridion.deployer.phases.PreCommitPhase.execute(PreCommitPhase.java:83) ~[cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.runMainExecutePhase(DeployPipelineExecutor.java:186) [cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.doExecute(DeployPipelineExecutor.java:97) [cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.execute(DeployPipelineExecutor.java:61) [cd_deployer.jar:na]
    at com.tridion.deployer.TransactionManager.handleDeployPackage(TransactionManager.java:80) [cd_deployer.jar:na]
    at com.tridion.deployer.queue.QueueLocationHandler$1.run(QueueLocationHandler.java:176) [cd_deployer.jar:na]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [na:1.6.0_26]
    at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) [na:1.6.0_26]
    at java.util.concurrent.FutureTask.run(Unknown Source) [na:1.6.0_26]
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source) [na:1.6.0_26]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.6.0_26]
    at java.lang.Thread.run(Unknown Source) [na:1.6.0_26]
2014-02-12 15:07:10,743 ERROR DeployPipelineExecutor - Unable to start processing deployment package with transactionId: tcm:0-5877-66560
  • Is the behaviour you are experiencing similar to this issue: stackoverflow.com/questions/14152009/… ? – Nickoli Roussakov Feb 7 '14 at 16:27
  • Yes similar to that one , but i did check those steps in the article you mentioned. I check dynamic_conf for publication mapping, sessionpreview webservice configuration (service paths in target etc.), session preview is not turned off also. Is there anything i could be missing ? – Stark Feb 7 '14 at 16:42
  • I suspect that my issue was due to using the File System deployer, rather than HTTP Upload. Which are you using? – Nickoli Roussakov Feb 7 '14 at 17:33
  • I am using HTTP Upload only. – Stark Feb 11 '14 at 13:22
  • 1
    @TheCoder Flagging a question for moderator attention will not help you in getting a resolution, if you require immediate support, then I suggest you contact SDL Tridion Customer Support. This site is a community initiative, by the community and for the community, it is provided at best effort. – Bart Koopman Feb 13 '14 at 9:10
4

I have also seen 404 issues appear when not enough time was granted to the Experience Manager and staging website mechanisms to update the changes and redisplay the page.

There is a setting in cd_storage_conf.xml to increase the session wrapper timeout allowed. By default this is 60 seconds (even when commented out), but it can be tuned and increased further, so to use this, uncomment it, and a good starting point is to double the existing value.

This is what it will look like out-of-the-box.

  <Wrapper Name="SessionWrapper">
                    <!--
                    Optional:
                    Timeout - The session timeout expressed in milliseconds.                     
                    <Timeout>60000</Timeout>
                    -->
3

Are you using any kind of URL routing in your web site? It is known that the out of the box Session Preview Module (.NET) and Filter (Java) won't work properly if the URL doesn't match with the file system.

You can get more details here Enabling Session Preview

  • No Eric, no url routing is involved here – Stark Feb 11 '14 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.