3

The Tridion publishing service on my CM machine, when attempting to start it, I get the error 'Service failed to start'

My transport service starts, but immediately stops as it's not being used.

Here's what I see in my event log:

TCDTransportService
Class 'Lcom/tridion/transport/TransportService;' not found

And when running the publisher in debug mode, I see that the files are correctly rendered, then the following error:

19:57:02.0621 <6468> Sending tranport package for transaction [tcm:0-145624-6656
0] with deploy control [Commit] to transport service.
19:57:26.4296 <6508> Error when calling method 'GetDeploymentNotification' of th
e object 'cd_transport.Transport'.
Retrieving the COM class factory for component with CLSID {FDD3F879-14B4-4492-9A
45-B640B3EA3E07} failed due to the following error: 80080005 Server execution fa
iled (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)).

19:57:56.4580 <6468> Retrieving the COM class factory for component with CLSID {
FDD3F879-14B4-4492-9A45-B640B3EA3E07} failed due to the following error: 8008000
5 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_
FAILURE)).

I'm running no other issues are found. I'm confident the issue is the missing Class, but I'm not sure where and how to fix this one.

4

It looks like Tridion admin user is not configured and also user should add as impersonation user.

Just come across existing question Configuring service account for publisher service, which ideally should solve your issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.