5

We are using tridion 2013 and this is our first implementation using Tridion and ASP.NET. While publishing any page or component the website becomes slow for first request due to ASP.NET dynamic compilation. How can we overcome this issue. Any suggestions are appreciated.

  • Can you give more details on your architecture. Are you publishing ASPX files? – Chris Summers Feb 21 '14 at 22:17
  • Yes we are publishing ASPX files from the CMS. – Husain Zahid Feb 22 '14 at 5:54
  • Does your publish action touch a top level item. That is changes in the BIN or App_Code folders, or to the global.asax or web.config. Any of these will cause a full website recompile. Changing a single ASPX file should not cause a restart of the site, just a recompilation of the page resource. – Chris Morgan Feb 22 '14 at 20:53
4

I think you need to disable batch compilation. You can do it in the web config.

<configuration>
      <system.web>
         <compilation batch="false">
      </system.web>
   </configuration>

However, I would recommend to pre-compile the asp .net web application before it is used.

| improve this answer | |
  • If we are publishing contents (as ASPX files) from the CMS, how can we precompile the application? – Husain Zahid Feb 22 '14 at 5:55
  • The tool to use for pre-compilation is the aspnet_compiler executable, which you can find in the %WINDIR%\Microsoft.NET\Framework\Vx.x.x directory. – Saurabh Gangwar Feb 22 '14 at 6:48
  • @hzahid, if your content is updated in regular basis then just disable batch compilation. – Eric Huiza Feb 22 '14 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.