I am installing Tridion 2013 SP1 in Microsoft Windows Server 2012 R2 64-bit, followed all the steps mentioned in the install manual for the section

Installing the Content Deployer (HTTP or HTTPS) as a .NET Web application

Browsing the HTTPUpload.aspx file from my web application which is under Tridion installation root category throwing the following error.

Unable to load DLL 'xmogrt': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

Error screenshot is attached.

Below are the list of dlls present in my application bin folder

  • netrtsn.dll
  • Tridion.ContentDelivery.AmbientData.dll
  • Tridion.ContentDelivery.Configuration.dll
  • Tridion.ContentDelivery.dll
  • Tridion.ContentDelivery.Interop.dll
  • xmogrt.dll

List of config files present in my application bin/config folder

  • cd_deployer_conf.xml
  • cd_storage_conf.xml
  • logback.xml
  • cd_licenses.xml

Point me where I am making a mistake.


  • 3
    Flagging this as a duplicate of tridion.stackexchange.com/q/4003/129 – Dominic Cronin Feb 27 '14 at 8:46
  • @Dominic I believe that answer was not accepted and no concrete solution is suggested. – P.Muralikrishna Feb 27 '14 at 14:54
  • @P.Muralikrishna is it resolved, please share the resolution – Raj Kumar Mar 4 '14 at 11:24
  • My bad forgot to install Microsoft Visual C++ 2010 Redistributable SP1, which is required to run java on windows. Thanks every one for your inputs. – P.Muralikrishna Mar 5 '14 at 5:46

Apart from @user978511 answer, mentioned error can cause due to not having enough permissions on the bin folder.

Unable to load DLL 'xmogrt': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

Verify AppPool Network Identity user has access rights on the bin folder and Install Microsoft Visual C++ 2010 Redistributable SP1.

| improve this answer | |
  • Network Identity user has access rights on the bin folder, still the same error... – P.Muralikrishna Feb 27 '14 at 11:16
  • @P.Muralikrishna: What are the rights given on it. – Siva Charan Feb 27 '14 at 17:18
  • Full control has been given on the bin folder to NETWORK Identity user – P.Muralikrishna Feb 27 '14 at 21:31
  • Thanks for the input, along with AppPool access on bin folder, installing Microsoft Visual C++ 2010 Redistributable SP1 solved my problem. – P.Muralikrishna Mar 5 '14 at 5:50

As far as I remember this dll should be available trough PATH environment variable. You can put it in the one of the folders which are listed in your PATH, or add bin folder to PATH

After you've done it, you can verify it by typing where xmogrt.dll in the command prompt. It should print you path to dll. Keep in mind that you will have to restart your IIS for the change to be applied.

You should also check that this dll is not Blocked, like this: enter image description here

| improve this answer | |
  • I have set the path of my bin folder as mentioned above, no luck... – P.Muralikrishna Feb 27 '14 at 11:15
  • One more observation: I am unable to start Tridion Content Deployer Service, ERROR: "Service on local computer started and stopped. Some services stop automatically if they are not in use by other services or programs" – P.Muralikrishna Feb 27 '14 at 11:37
  • Check event log and ask it as a separate question – Andrey Marchuk Feb 27 '14 at 11:59
  • If you are running the deployer in IIS, the PATH variable is totally not needed. In fact, it may work counter productive. You can check the Content Delivery Windows event log to see which path the deployer is actually trying to access to load the Tridion DLLs. – Raimond Feb 28 '14 at 7:57

in addition to whatever experts have mentioned above.

Please Make sure all Dlls & JAR files are 64 bit.

| improve this answer | |
  • Every DLL I am using is 64 bit cross checked again... – P.Muralikrishna Feb 27 '14 at 11:17
  • Its about all DLL and JARs, also is Java version(major.minor) compatible and 64 bit? – Raj Kumar Feb 27 '14 at 15:41
  • I am following the Tridion installation manual and copied all the DLLs, JARs including Java version(1.7) as specified – P.Muralikrishna Feb 27 '14 at 21:29

Delete the xmogrt dll from your place, re-copy it from the Tridion Installation CD as per the Installation Manual, paste it again. Recycle your app pool and try again

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.