2

Recent upgrade from Tridion 2011 SP1 to Tridion 2013 SP1. WebDAV maps correctly and we can navigate to directories and see lists of .JPGs for instance; however, when we navigate to the folders containing PDFs no items are returned in Windows Explorer.

The Tridion error logs contained a ton of these messages:

No items found for WebDAV URL(s):

/webdav/**/Building%20Blocks/Content/Multimedia%20Components/pdf/desktop.ini.

Component: Tridion.ContentManager.CoreService

Errorcode: 512

User: NT AUTHORITY\NETWORK SERVICE

StackTrace Information Details: at Tridion.ContentManager.UrlConversion.Convert() at Tridion.ContentManager.Session.GetTcmUri(String uri) at Tridion.ContentManager.Session.GetObject(String uri) at Tridion.ContentManager.CoreService.CoreServiceBase.GetSubject(String id, ReadOptions readOptions) at Tridion.ContentManager.CoreService.CoreServiceBase.Read(String id, ReadOptions readOptions) at SyncInvokeRead(Object , Object[] , Object[] ) at System.ServiceModel.Di

The machine is Windows 2008 R2 SP2. Desktop Experience and Ink Support are installed. The Web Client service is running.

Any ideas would be greatly appreciated? Thanks

2

I've tested it on my local 2013 SP1 instance and the pdf files don't show up either.

What I can conclude from this is that only image based Multimedia items show up when accessed via Webdav.

As far as the warning message you mentioned above goes, when you access Webdav using Windows Explorer, Windows Explorer requests 2 files on its own (desktop.ini and Thumbs.db) which do not exist on the Tridion system leading to the warning being shown in the logs.

If you want to stop seeing the warning messages you could encourage the users to use 3rd party Webdav clients like AnyClient :)

1

On my 2013 SP1 instance (Windows Server 2008 R2) it seems to be working just fine, I have a Folder with a couple of JPG images, a PDF and a TXT file. I can see all in the WebDAV folder and can open them, delete them and even upload them again.

So with the error you are facing I can only suggest to contact Customer Support and check with them, as it seems something unexpected is going wrong.

I have to add, I've always found WebDAV to be extremely bad for your log. It seems to generate a lot of warnings and errors in the process of trying to determine what to do, and even when from a user perspective everything went well (like my successful tests of opening, deleting and creating items through WebDAV), the log still contains warnings and errors (some of them indeed the expected missing desktop.ini and Thumbs.Edb, which are a failure in Microsofts WebDAV client).

It is a funny and useful protocol, but terribly slow unfortunately. Nevertheless, it should work, even with PDFs.