5

Does anyone have a list of steps to follow for configuring WebDAV on a server? When I try to connect from explorer on a Win 7 PC I get a "The folder you entered does not appear to be valid..." message.

The issue is not with my client PC since I can connect thru webdav to a different tridion cm. The configurations looks similar though. For example, the WebClient service is running on both servers.

  • Have you tried to map a drive to the WebDAV target path? Same error message? – DanielGLB Mar 18 '13 at 22:59
  • 1
    To troubleshoot issues on the server, it can be useful to check the IIS logs of the CM Server for the Content Manager Explorer website. Search for /webdav and you should see a detailed IIS error code, which might give a clue to the issue... – Will Price Mar 19 '13 at 6:45
  • What security do you have on your website, is it LDAP, or SSO, or just Windows authentication? – Andrey Marchuk Mar 19 '13 at 8:01
5

WebDAV

On the taskbar, click Start, point to Administrative Tools, and then click Server Manager. In the Server Manager hierarchy pane, expand Roles, and then click Web Server (IIS). In the Web Server (IIS) pane, scroll to the Role Services section, and then click Add Role Services. On the Select Role Services page of the Add Role Services Wizard, expand Common HTTP Features, select WebDAV Publishing, and then click Next. On the Confirm Installation Selections page, click Install. On the Results page, click Close.

Enabling WebDAV (After installation of the tridion content manager)

In IIS Manager, in the Connections pane, expand the Sites node in the tree, then click the SDL Tridion 2009 Web Site, select the virtual directory webdav, double-click the WebDAV Authoring Rules feature. When the WebDAV Authoring Rules page is displayed, click the Enable WebDAV task in the Actions page. Once WebDAV has been enabled, click the Add Authoring Rule task in the Actions pane. When the Add Authoring Rule dialog appears: Click All content to specify that the rule applies to all content types. Choose "All users" Select Read, Source, and Write for the permissions. When you have completed these items, click OK. For a detailed description go to: http://learn.iis.net/page.aspx/350/installing-and-configuring-webdav-on-iis-7/

| improve this answer | |
5

Try double-checking the domain, user, and/or password and if there are any special characters in the path.

Server-side Setup

WebDAV is enabled server-side by default in IIS 7.0 and 7.5.

Client-side Setup

Abbreviated from the online documentation (requires login):

  1. Add the WebDAV server to My Network Places by right-clicking My Computer and select Map Network Drive
  2. Follow the wizard instructions to connect to the URL of the CMS followed by /webdav (e.g http://cms-site/webdav).
  3. Specify credentials to connect to this URL as DOMAIN\USERNAME and password.

Also note you cannot browse to folders that have the following characters per SDL Live Content:

< & > # % * : | ~ +

Folders with these names must be opened in the Content Manager Explorer, or renamed to be opened with WebDAV.

| improve this answer | |
3

This might also help you (or anyone viewing this question in the future): https://stackoverflow.com/questions/9912115/connecting-to-sdl-tridion-webdav-via-windows-explorer-windows-2008-r2

"You probably need to install the Desktop Experience feature to make this work from the server. See http://technet.microsoft.com/en-us/library/cc772567.aspx for details"

| improve this answer | |
  • Good info that comes up often when trying to do WebDAV on the server itself, typically in a development VM. This answer deserves its own question (hint hint). – Alvin Reyes Mar 19 '13 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.