29

I am developing a GUI Extension and am having some issues identifying some errors in my code.

I am seeing errors that include the name of my extension but the code is minified so the line looks like:

Error showing minified line

Is there a way to turn off JavaScript minification in the CME so that I can see the actual code causing this error?

32

On the Content Manager Server locate System.config this is found in %TRIDION_HOME%\web\WebUI\WebRoot\Configuration

Locate the following element:

<filter for="Script" type="Tridion.Web.UI.Resources.Filters.JScriptMinifier, 
               Tridion.Web.UI.Resources.Filters" enabled="always">

Replace the value for the enabled attribute to read "never"

<filter for="Script" type="Tridion.Web.UI.Resources.Filters.JScriptMinifier,
               Tridion.Web.UI.Resources.Filters" enabled="never">

Then increment the modification value on the System element

<server version="6.1.0.55920" modification="22">

Refresh your browser. You should now be able to see the actual code causing the error and line number in your browser script debugger e.g. Firebug.

Please note this should really only be done on a development environment as this will drastically increase the amount of javascript that will be downloaded by anyone using the CME.

| improve this answer | |
11

I have this in my powershell profile. Basically, it's the same answer as Rob's.

function SetGuiMinification($value){
  $filename = 'C:\Program Files (x86)\Tridion\web\WebUI\WebRoot\Configuration\System.config'
  $conf = [xml](gc $filename)
  $conf.Configuration.filters.filter |?{$_.type -like '*JScriptMinifier*'} |%{$_.enabled = $value}
  $conf.Save($filename)
  iisreset
}

"guimin"
function guimin {SetGuiMinification "always"}
"guinomin"
function guinomin {SetGuiMinification "never"}
| improve this answer | |
  • Follow Dominic's example. Always use a script to modify XML config files, you will have to make the same change in your other environments. You don't want your environment configurations to drift apart. – Chris Mills Jul 2 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.