3

I have setup a new SDL Tridion 2013 environment and when I am accessing the GUI, it is giving:

Unable to Connect to Remote Server

Any help?

Update

I found some error in this log file, "Tridion Audience Manager.OETrigger.log":

[Error] Could not connect to net.tcp://localhost:2660/CoreService/2013/netTcp. No connection could be made because the target machine actively refused it 127.0.0.1:2660

  • Check event viewer and let us know what exactly can't be connected. I believe it's one of the databases – Andrey Marchuk Apr 11 '14 at 12:17
  • There is nothing in the Event Viewer. I have checked that. Also, sometime it works, but sometime it gives this error. – Sharad Sangal Apr 11 '14 at 12:22
  • Can you get stack trace from the error? If there's nothing in event log then you should check logs of addons, like Outbound email, etc – Andrey Marchuk Apr 11 '14 at 12:23
  • Are you connecting to CME remotely from your own PC/laptop, or from within the server itself? – Hao Peng Apr 11 '14 at 14:22
6

For us, it was an issue with the Tridion\web\WebUI\WebRoot\Web.config files configuration of the appSettings <add key="Tridion.WCF.RedirectTo" value="localhost:80"/>. The port number was off somehow and that was throwing the error.

|improve this answer|||||
  • 1
    This is sometimes called if the Tridion CME is installed with the default IIS website (that already uses port 80) still in place. This causes the setting to be <add key="Tridion.WCF.RedirectTo" value="localhost:81"/> – Jonathan Williams Jul 7 '14 at 8:43
2

By default, Windows disables connections back to the loopback interface. That would give you these symptoms. You can find instructions to fix this configuration at http://support.microsoft.com/kb/896861

As far as I can remember, this is also mentioned in the Tridion documentation.

|improve this answer|||||
1

I assume that your ServiceHost is running? If it's indeed running, you may take a look at: http://amarchuk.blogspot.nl/2013/07/coreservice-throttling.html

It might be the case that you have more than 16 clients connecting, at the same time, especially if take into account that each instance of UI is occupying at least 2 (CME and Audience Manager). It's quite possible that once in a while you have all 16 slots busy and extra clients got rejected. Check if you have long running calls running calls being executed on this endpoint and try to fiddle with values from the blog.

|improve this answer|||||
  • I don't think this is the issue as only 2 instances are being used as of now. Its is totally a new setup. The no. of instances will increase but once it starts working smoothly. I am thinking to revisit the configuration for all Add-Ons and see if the problem gets resolved. Thanks & Regards Sharad Sangal – Sharad Kumar Sangal Apr 11 '14 at 20:03
1

An active refusal of a connection made to a port usually means your Windows Firewall does not have port 2660 open, so the connection is reset. The other reason may be that the Core Service Host Service is not running. So, open up the firewall to local host and ensure the service is running.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.