6

I have configured HTTP upload "by the book", using the pre-packaged web application in

"installer directory"\Content Delivery\roles\upload\dotNET\webapp\x86_64\upload.zip

When accessing the HTTPUpload.aspx page to test it, I get the following error:

A process serving application pool 'upload.visitorsweb.local' suffered a fatal
communication error with the Windows Process Activation Service. The process id 
was '3812'. The data field contains the error number.

I can see that sometimes when this happens, the application pool stops, but re-starting it doesn't help. The only useful item in the logs seems to be the message above.

I'm running Windows Server 2012 using SDL Tridion 2013.

What might be the cause of this, and where could I investigate further?

EDIT: Note that the error above was found in the Windows logging. The log files you might have expected to be generated by Tridion CD libraries were entirely empty. In the light of the eventually discovered cause, this is a significant diagnostic indicator.

  • Which version of Tridion is this for? – Alvin Reyes Mar 20 '13 at 8:11
  • Tridion 2011 does NOT support Windows 2012 - more than that, it will actually not work because of an incompatibility with between Juggernet and IIS 8 – Nuno Linhares Mar 20 '13 at 8:59
  • Indeed - I am using a preview version of Tridion 2013 – Dominic Cronin Mar 20 '13 at 15:07
6

Not sure if the Tridion Version is 2011 or 2013, but regardless, could you check your JRE/JDK versions and ensure they are working fine...Also, can you try both 32-bit and 64-bit JDK versions simultaneously on your server?

  • This looks promising... When I type "java -version", I get: "Error occurred during initialization of VM java/lang/NoClassDefFoundError: java/lang/Object". Looks like java didn't install properly. Investigating further – Dominic Cronin Mar 20 '13 at 15:33
  • Indeed - that was it. I have re-installed Java and now it works. (Even more frustrating is that I have a recent memory of a Java 6 installer causing similar problems, but I wasn't smart enough to join the dots by myself. Note to self: always test the java install straight away.) For the record, it's Tridion 2013 and all 64 bit. Thanks. – Dominic Cronin Mar 20 '13 at 16:03
5

In case it is Juggernet:

I am not a fan of Juggernet's wrappers, I'd personally have a separate java CD server running on Linux without wrappers, but anyway that's another topic.

In order to test if Juggernet is working, in the past, I created an ASPX file (see below) which you could save next to the HttpUpload.aspx. It basically tests if the Juggernet can be instantiated and if it can find the JVM, which is all the basis for the ContentDelivery.Transport.HttpUpload process.

<%@ Page Language="C#" %>
<%@ Import namespace="Codemesh.JuggerNET" %>
<%
    IJvmLoader    loader = JvmLoader.GetJvmLoader();
    //loader.JvmPath = @"C:\Java\jre6\bin\server\jvm.dll";
    %>JVM Path:<%=loader.JvmPath%><%
    IJvm jvm = null;

    try {
        if( loader.JvmPath == null )
        {
            %>loader.JvmPath is null, trying to load a JVM something<%
            loader.JvmPath = @"C:\Program Files\Java\jre6\bin\server\jvm.dll";
        }   

        jvm = loader.Load();
    }
    catch( System.Exception se ) {
        %>JVM couldn't be loaded<%=se.ToString()%><%
    }

    try {
        if( jvm != null ) {
            ; %> JVM Loaded<%
        }
        else {
            ; %> JVM Not loaded<%
        }
    }
    catch( System.Exception se ) {
        ; %>Missing JVM<%
    }
%>
2

A process serving application pool '%1' suffered a fatal communication error with the Windows Process Activation Service. The process id was '%2'. The data field contains the error number.

When I was trying to investigate, I come across few points which may cause above issue:

  1. Refer Event ID 5011 — IIS Application Pool Availability for more details

    Diagnose an unresponsive worker process:

    A worker process that fails to respond may exhibit one of the following symptoms:

    • Ping failure.
    • Communication failure with WAS.
    • Worker process startup time-out.
    • Worker process shutdown time-out.
    • Worker process orphan action failure.
  2. Make sure that Application Pool in IIS, under "Advanced Settings" has "Enable 32 bit Applications" set to "False" (If it is 64-bit)

  • Thanks Siva. Unfortunately, this didn't get me much further. It is a 64bit server, and 32 bit is set to false. Beyond that, the debug analysis tool looked useful, but on this occasion didn't turn up the answer. – Dominic Cronin Mar 19 '13 at 21:27
2

Windows Server 2012 is not on the list of supported platforms for 2011/2011SP1 but I tried it a few times to check how it works. As far as I remember, I had to install 'Microsoft Visual C++ 2010 Redistributable SP1' to make is work. Can you please try to install that and see if it solves the problem?

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.