0

When I can an image component , it shows me tcm id of the new image and shows the image once i published the page which should not be the case. Because if I am changing any component it should inhand show on the editor atleast.

  • Sorry, but you really need to add some context here. I see image previews just fine in the CME - how are you adding this image, what are you adding it to? In Rich Text Field, in image field? – Nuno Linhares Apr 27 '14 at 9:59
  • I have an image field(not in Rich text field) in my component.I am trying to change this component via experience manager. I am able to change the image in this component by selecting from other available multimedia components. When I say "Apply" image component gets changed but it shows me tcm uri instead of new image. – user918 Apr 27 '14 at 14:42
  • That helps clarify, please add the details to the question to help others follow. Your template markup and outputted page (with SiteEdit comments) will also help. The next question is if your image shows on Update Preview or after pressing Finish Editing which publishes the page. Aside from your template, XPM also has Session Preview image size limits that may affect how images display. – Alvin Reyes Apr 27 '14 at 17:11
  • My guess is that it's only showing the TCM ID before session preview, and after update the image will be loaded. – Nuno Linhares Apr 27 '14 at 18:48
  • 1
    Yes you need Session Preview to be fully configured to be able to swap images from XPM and see them appear right away, without having to click "Finish Editing" then wait for publishing to happen and then reload the page to see the image. In your case the first thing to do is open the Publication Target settings from the Content Manager Explorer and make sure that the URL of your preview website is listed correctly in the Session Preview tab. Also make sure that the "Enable for inline editing" checkbox is checked in the General tab of the publication target. – Philippe Conil Apr 28 '14 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.