4

I have created a component, That component contains Russain content. This content is stored as "???" in the Broker database.

In DD4T web application debugging mode component's data shown as "???". Is there any setting i am missing?

5
  • 1
    This question is going to need more detail before people can answer it. Firstly - if you are talking about what the data looks like when you look at it directly using database browsing tools, then this is expected. See tridion.stackexchange.com/q/2967/129. If it's something else (i.e. you've tried actually putting the data on a page and it still doesn't display well) then please add some details about your encodings, publishing process etc. Please explain what you've tried, and what doesn't work.
    – Dominic Cronin
    Apr 27 '14 at 8:24
  • I have tried to create a component with Russian content and publiched to broker database. And accessed that component from DD4T web application. Coponent's data is shown as "????" in debugging mode.
    – Senthil
    Apr 27 '14 at 9:39
  • Just checked creating a static publishing model. there also content is published to .Html file as "?????".
    – Senthil
    Apr 27 '14 at 10:02
  • 1
    So this was an encoding issue caused by Publication using Default Code Page. Were all the characters actually question marks?
    – Alvin Reyes
    Apr 27 '14 at 17:07
  • Yes Correct Alvin
    – Senthil
    Apr 28 '14 at 8:58
7

I would suggest setting your ASP.NET MVC (DD4T) app to use UTF-8 encoding. http://msdn.microsoft.com/en-us/library/hy4kkhe0%28v=vs.71%29.aspx

4
  • UTC encoding are correctly set. It is issue in Tridion. Because content is published as "????" instead of actual content
    – Senthil
    Apr 27 '14 at 10:03
  • 2
    If UTF8 is properly configured then content is published correctly. This has been true for thousands of websites with Tridion before, it won't be different for you. Something is missing - Check Elena's 7 clues: elenaserghie.blogspot.nl/2012/01/…
    – Nuno Linhares
    Apr 27 '14 at 10:06
  • Publication changed Default Code Page set as default setting, I have changed that to UTF8. Now it is working fine.
    – Senthil
    Apr 27 '14 at 10:17
  • Great. Glad it's working now
    – Nuno Linhares
    Apr 27 '14 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.