4

I am having issues with my Content Porter 2013 SP1 client connecting to the Tridion CMS server. My error is 'Could not find SDL Tridion Content Manager server...'. However, I can connect to the same server with the GUI.

We have 2 bindings in IIS: - loalhost - url based

Fiddler gives me "HTTP/1.1 500 System.ServiceModel.ServiceActivationException"

We did not have this problem with the Core Service in Tridion 2011.

I installed it with the Google ClickOnce tool and it saved the local ContentPorter 2013 SP1 files here: C:\Users\UserName\AppData\Local\Apps\2.0\8BKMWX5H.E77\HHPXJGL0.8LX\cp.a..tion_cefdd28298bce0cb_0003.0004_dcbe3a7bb47e778a

And, I have a cp.exe file there, and also an interesting /config folder with 2 files inside: - system.servicemodel.bindings.config - system.servicemodel.client.config

I found this binding and tried the URL in a browser, but get the .Net default YSOD page:

<endpoint name="ImportExport_basicHttp_f6a43d3b-941b-4d72-8e45-621761653bef" address="http://dev.tridion-server.com:80/webservices/ImportExportService2013.svc/basicHttp" binding="basicHttpBinding" bindingConfiguration="ImportExport_basicHttpBinding_http" contract="Tridion.ContentManager.ImportExport.Client.IImportExportService" />

What are the next steps for troubleshooting? I have the feeling my Core Service on the server is not working well.

Event Log:

    WebHost failed to process a request.
     Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/53129168
     Exception: System.ServiceModel.ServiceActivationException: The service '/webservices/ImportExportService2013.svc' cannot be activated due to an exception during compilation.  
The exception message is: This collection already contains an address with scheme http.  

There can be at most one address per scheme in this collection. If your service is being hosted in IIS you can fix the problem by setting 'system.serviceModel/serviceHostingEnvironment/multipleSiteBindingsEnabled' to true or specifying 'system.serviceModel/serviceHostingEnvironment/baseAddressPrefixFilters'.

    Parameter name: item. ---> System.ArgumentException: This collection already contains an address with scheme http.  There can be at most one address per scheme in this collection. If your service is being hosted in IIS you can fix the problem by setting 'system.serviceModel/serviceHostingEnvironment/multipleSiteBindingsEnabled' to true or specifying 'system.serviceModel/serviceHostingEnvironment/baseAddressPrefixFilters'.
  • Enable WCF tracing on core service and check the trace – Andrey Marchuk Apr 28 '14 at 11:43
7

The answer is in the error message:

If your service is being hosted in IIS you can fix the problem by setting 
'system.serviceModel/serviceHostingEnvironment/multipleSiteBindingsEnabled' to true or
 specifying 'system.serviceModel/serviceHostingEnvironment/baseAddressPrefixFilters'.

WCF never allows to have two endpoints in a service model configuration with the same scheme (http, net.tcp, etc.). My recommendation would be to only have the localhost endpoint as endpoint configuration and to let IIS handle incoming requests from other machines.

  • 1
    Perfect solution - enabled only the localhost endpoint and it is solved. Really liking the 2013 SP1 Content Porter a lot more :) – robrtc Apr 29 '14 at 9:32
  • 1
    Perfect, same issue while using Web 8 Content Porter. saved by this Awesome post, just removed other binding in IIS. – Ashutosh May 10 '16 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.