1

I am trying to use WebDAV URL in Visio external activity class to refer to a workflow assembley below is the code for same

AssemblyTbbId = "/webdav/020%20Asia%20Schema%20Master/Building%20Blocks/System/WorkFlow/CompanyName.ADD.Test.Tridion.WorkFlow.tbbasm" 

Type = "CompanyName.ADD.Test.Tridion.WorkFlow.BundleWorkFlowProduct"

But once i save this in tridion and it is getting changed into the TCMID instead of WebDAV URL. What is going wrong here. This is default behavior or do i need to do something else

AssemblyTbbId = "tcm:30-3088-2048" 

Type = "CompanyName.ADD.Test.Tridion.WorkFlow.BundleWorkFlowProduct"
2

It is correct behavior. AssemblyTbbId follows "managed link concept". On saving process definitions Tridion analyzes all external activities, extracts managed links and converts them to TcmUri. TcmUri-s are saved to database as well (also associations are created for whereUsed-WhereUsing functionality). For getting webDavUrls in Script you need to load ProcessDefinition with WebDavUrl flag (for example with CoreService). In Workflow designer we assume - you don't need WebDavUrl-s.

Btw, the same concept is used for compound templates. You can save them with references to WebDavUrl-s (and without titles specified). But when you save that in UI - you'll get processed template content with TcmUri-s and titles of the referenced templates.

| improve this answer | |
1

The thing is that it's always being saved as TcmUri as this is the only consistent identifier of item across tridion (as WebDAV url will change if you move item, for example). For this reason WebDAV url is generated at runtime, when necessary, i.e. when you read an item and ask for it. So, to answer your question, the behavior is correct, you would see uri as WebDAV url, if Workflow Designer would ask for it (with appropriate LoadFlag), but it doesn't.

| improve this answer | |
  • Want to add only, that WebDavUrl prefix can be changed :). After that all webDavUrls become incorrect. That's one of the reason, why TcmUris are used always on saving. – Syav4eg May 7 '14 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.