In the blueprinting hierarchy we had component template at level 3 (global) and component also at level 3 in another publication. We were able to reference component / component template in page without any issue.

Recently, since more sites are added to Tridion we had move component template to level 4 from level 3. Level 4 is specific to the site. After the movement we removed folder permission from folder containing component template at level 3 (global) and granted permission to the folder containing component template at level 4.

However, we are still seeing old component template (from level 3) and not seeing the component template at level 4 when adding component to the page.

Can you please suggest what are we missing?

  • Are the permissions to groups that your user actually belongs to and could your level 4 folders be localized (or not localized) as needed? If the level 4 folders are localized, then they potentially have different permissions than the parent versions of those folders. Also make sure your new template is checked in.
    – Alvin Reyes
    May 16 '14 at 20:38
  • @AlvinReyes permission is given to the active directory group and item is not localized, template is checked in.
    – Hiren Kaku
    May 16 '14 at 20:48
  • If you get an error selecting the level 3 template, then your settings are likely right and it's maybe a browser caching issue (clear cache, try another browser, etc). But if it lets you use the wrong template, double check permissions: look for exceptions, group membership (a parent group giving/denying permissions), and settings for "everyone," or if the user happens to be an admin (and can see everything).
    – Alvin Reyes
    May 17 '14 at 0:05

The GUI caches some things quite aggressively, and I suspect that the list of component templates is being cached. You might even be able to create the component presentation, and save the page, as I don't think either of these actions involves reading the component template.

Obviously, you have to check all your permissions very thoroughly - in particular, a common reason for still being able to see something after permission removal is that the user still has the permission via another group. However, this won't explain why you can still see the old one, so I'm betting on caching being the problem.

Close the browser entirely, flush the cache, try again. Or for a really definite test, use a different browser - preferably one that's never been used to access Tridion.

  • I tried above options however still the same issue. Also, one more thing to note, administrators see both the templates i.e. at level 3 and level 4 both.
    – Hiren Kaku
    May 19 '14 at 18:35
  • That indicates that it's not a permissions issue. Administrators aren't affected by permissions.
    – Dominic Cronin
    May 20 '14 at 4:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.