4

I am getting below error while doing fresh installation. I tried installation with MTS user user but getting the same error. When I pressed Retry It installed the TRIDION successfully. But failed to start Tridion transport and publisher services after Installation and I can see below error in Event logs :

Class 'Lcom/tridion/transport/TransportService;' not found

enter image description here

  • Are you installing it "Run as administrator"? – Raj Kumar May 29 '14 at 11:43
  • Yes we are installing as administrator – AlokBhatt May 29 '14 at 12:06
  • Did you manage to resolve this? – Jonathan Williams Jun 11 '14 at 22:17
8

You may want to double-check that you have a valid cd_license.xml file on your CM server.

I recently upgraded a client's server from Tridion 2013, where everything was working fine without a cd_license.xml file, to 2013 SP1, and the Publisher & Transport Services wouldn't start without it.

UPDATE (03/07/2014): It appears that this was a bug in Tridion 2013 GA. The cd_license.xml is needed on the Content Manager server (for the Publisher and Transport Services), but Tridion 2013 GA never checked that it was present.

If you don't already have it, then you may need to request a license from SDL for this (it requires the machine name and the CPU count from the CM server).

2

I did faced the exact issue that you are mentioning while first time installing SDL Tridion 2013 SP1. I did following to resolve it:

  1. Checked and verify that none of the dependency I am missing which is being required by SDL Tridion. You may want to Follow THIS great post from Alvin and carefully follow all steps without a miss
  2. Un-install the Tridion and Re-install it again (and ensure you start the process as administrator) and again ensure you have resolve all the dependency first before you execute the installer.
  3. You may choose to install the Core first and then additional items one by one to further dig which module is creating problem if the step 2 does not resolve your problem

I hope it helps.

  • Pankaj! can you please share the link? While installation it is checking for dependencies and it says that no dependency is missing. – AlokBhatt May 30 '14 at 5:02
  • Was is the Tridion 2013 VM post? I made it against Tridion 2013 GA rather than SP1, so be sure to follow the latest for your version (see SDL Live Content). – Alvin Reyes Jun 1 '14 at 18:14
1

Please refer following link

, it seems similar issue. if it does not resolve, you can re-verify the steps.

0

I had similar initial error and different errors in Event log when installing only Publisher. The problem was missing CM server prerequisite that installer did not detect: Microsoft Visual C++ 2010 Redistributable SP1 (x64), see 2013 SP1 SDL documentation for download link: Content Manager server prerequisites

Installing it manually resolved the issue and Transport and Publisher services could be started.

---------------- Details:

Similar part: Running 2013 SP1 installer and trying to install only "Publisher Service" from Advanced View, I've got similar error during installation "Service 'Tridion Content Manager Publisher' (TcmPublisher) failed to start. Verify that you have sufficient privileges to start system services." Installation proceeded after clicking on "Retry", unfortunately after machine reboot, Transport service is not started.

Different part: Event log contains 2 errors after I've tried to manually start Transport service:

---------------- Error1

Log Name: Application Source: .NET Runtime Date: 12/3/2014 7:42:19 PM Event ID: 1026 Task Category: None Level: Error Keywords: Classic User: N/A

Description: Application: cd_transport.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.AccessViolationException Stack: at Tridion.Common.Java.Activation.Launcher.LaunchInternal[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089] at Tridion.Common.Java.Application1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].LaunchWith(Tridion.Common.Java.Activation.Launcher) at Tridion.ContentDistributor.Transport.<.cctor>b__0() at System.Lazy1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].CreateValue() at System.Lazy1[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].LazyInitValue() at cd_transport.Service.OnStart(System.String[]) at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(System.Object) at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() at System.Threading.ThreadPoolWorkQueue.Dispatch()

---------------- Error2

Log Name: Application Source: Application Error Date: 12/3/2014 7:42:19 PM Event ID: 1000 Task Category: (100) Level: Error Keywords: Classic User: N/A

Description: Faulting application name: cd_transport.exe, version: 7.1.0.165, time stamp: 0x527feb17 Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000 Exception code: 0xc0000005 Fault offset: 0x0000000000000000 Faulting process id: 0x8e0 Faulting application start time: 0x01d00f28de181f15 Faulting application path: C:\Program Files (x86)\Tridion\bin\cd_transport.exe Faulting module path: unknown Report Id: 1be2ef99-7b1c-11e4-80cd-005056876143 Faulting package full name: Faulting package-relative application ID:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.