2

I am getting the below error when I click the "Update Preview" or Finish Editing button after making content changes for both normal and rich text fields in the Experience Manager in SDL Tridion 2013. I am not sure what is causing this.

((Unable to update the changes using OData Service. An error occurred while processing this request.
<?xml version="1.0" encoding="UTF-8" standalone="yes"?> 
<error xmlns="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"
 xmlns:atom="http://www.w3.org/2005/Atom"
 xmlns:edmx="http://schemas.microsoft.com/ado/2007/06/edmx"
 xmlns:d="http://schemas.microsoft.com/ado/2007/08/dataservices"
 xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata"> 
<code></code> 
<message xml:lang="en-US">The input data was invalid: Content field required., 
  Content field required., Content field required.</message> 
</error>))

This is the odata cd_core Log details:

2014-05-21 10:05:21,296 DEBUG SessionServiceImpl - Loadin...2014-05-21 10:05:21,296 DEBUG SessionServiceImpl - Loading previewSessionItems and previewSessionPublicationMappings for session ff7cdee1-100b-4166-9699-07e1e39a4341.

2014-05-21 10:05:21,296 DEBUG JPAPreviewSessionItemDAO - Retrieving PreviewSessionItems by sessionId: ff7cdee1-100b-4166-9699-07e1e39a4341. 2014-05-21 10:05:21,296 DEBUG JPAPublicationMappingDAO - Retrieving PublicationMapping by mappingKey: ff7cdee1-100b-4166-9699-07e1e39a4341.

2014-05-21 10:05:21,312 DEBUG JPAItemDAO - Removing binary meta from storage

2014-05-21 10:05:21,328 ERROR SessionWrapperFactory - Exception while cleaning-up session data: Error while committing the transaction, Error while committing the transaction

2014-05-21 10:06:20,948 DEBUG HttpModule - Dispose 8:20 AM

UPDATE - I have tried with all sorts of components and fields having mandatory, non - mand, text, rich text but the error persists. I have attached the fiddler error details as well below. Pls have a look and suggest. Also the log are not captured inline with the error details this time failure to which the troubleshooting has become more difficult.

Analysis done – 1) We have checked the storage config for the website and odata , both are in sync and pointing to the same session db. Still no data is getting into the Component_Presenatations table of session preview db on “Update Preview”.

2) Checked the ambient config for the website and odata and both have the necessary preview cartridge file.

3) Checked the cd_core log for odata in DEBUG and here are the logged information –

2014-06-03 04:56:46,128 DEBUG SessionServiceImpl - Loading previewSessionItems and previewSessionPublicationMappings for session ff7cdee1-100b-4166-9699-07e1e39a4341.

2014-06-03 04:56:46,128 DEBUG JPAPreviewSessionItemDAO - Retrieving PreviewSessionItems by sessionId: ff7cdee1-100b-4166-9699-07e1e39a4341.

2014-06-03 04:56:46,128 DEBUG JPAPublicationMappingDAO - Retrieving PublicationMapping by mappingKey: ff7cdee1-100b-4166-9699-07e1e39a4341.

2014-06-03 04:56:46,143 DEBUG JPAItemDAO - Removing binary meta from storage

2014-06-03 04:56:46,143 ERROR SessionWrapperFactory - Exception while cleaning-up session data: Error while committing the transaction, Error while committing the transaction

2014-06-03 04:57:34,735 DEBUG HttpModule - Dispose

2014-06-03 04:57:34,735 DEBUG HttpModule - Dispose

2014-06-03 04:57:34,735 DEBUG AmbientRuntime - Ambient Runtime release.

2014-06-03 04:57:34,735 DEBUG AmbientRuntime - Ambient Runtime release.

4) Fiddler response shows 500: Internal server error and jsonerror: true on the below request.

POST /WebUI/Models/SiteEdit/Services/Services.svc/GetPreviewToken HTTP/1.1

Host: sn

Connection: keep-alive

Content-Length: 1218

Authorization: Negotiate YIIHmwYGKwYBBQUCoIIHjz

X-SDL-Tridion-Token: 1401879453371

Origin: http://

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

Content-Type: application/json; charset=UTF-8

Accept: /

Referer: /WebUI/Editors/SiteEdit/Views/Editor.aspx

Accept-Encoding: gzip,deflate,sdch

Accept-Language: en-US,en;q=0.8

Cookie: L%3AJS=1033;rest deleted for clarity

{"publishedItemsInfo":[{"ItemId":"tcm:79-35348-64","TemplateId":"tcm:79-35142-128","ItemLastModifiedTimeStamp":"/Date(1400487931000)/","TemplateLastModifiedTimeStamp":"/Date(1397795965000)/","ComponentPresentationType":0},{"ItemId":"tcm:79-35583","TemplateId":"tcm:79-33975-32","ItemLastModifiedTimeStamp":"/Date(1401784140000)/","TemplateLastModifiedTimeStamp":"/Date(1401686821000)/","ComponentPresentationType":1},{"ItemId":"tcm:79-35398","TemplateId":"tcm:79-33970-32","ItemLastModifiedTimeStamp":null,"TemplateLastModifiedTimeStamp":"/Date(1398988147000)/","ComponentPresentationType":1},{"ItemId":"tcm:79-35125","TemplateId":"tcm:79-33971-32","ItemLastModifiedTimeStamp":"/Date(1401161776000)/","TemplateLastModifiedTimeStamp":"/Date(1397797848000)/","ComponentPresentationType":1},{"ItemId":"tcm:79-35128","TemplateId":"tcm:79-33971-32","ItemLastModifiedTimeStamp":"/Date(1401334339000)/","TemplateLastModifiedTimeStamp":"/Date(1397797848000)/","ComponentPresentationType":1},{"ItemId":"tcm:79-35400","TemplateId":"tcm:79-35555-32","ItemLastModifiedTimeStamp":null,"TemplateLastModifiedTimeStamp":"/Date(1400111378000)/","ComponentPresentationType":1}],"publishingTargetId":"tcm:0-11-65537"}

1

Did you check are there any hotfixes released to same type of problem on sdltridionworld website? I checked few hotfixes exist for tridion 2013 release. I hope those hotfixes resolves your problems.

I suggest you to apply hotfixes and try again. Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.